AC problem that I havent seen an answer for. - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Feb 17th, 2019, 10:06 PM Thread Starter
NissanForums Newbie
 
Joined: Feb 2019
Posts: 3
Hi, I'm having the opposite problem as most I've seen. My AC seems to run fine at an idle but when I start driving, it starts blowing warm air! Any help would be greatly appreciated! Thanks.


Last edited by Rooster22; Feb 17th, 2019 at 10:10 PM. Reason: Forgot to put the year! 06 Titan
Rooster22 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Feb 21st, 2019, 06:06 AM Thread Starter
NissanForums Newbie
 
Joined: Feb 2019
Posts: 3
AC problem that I havent seen an answer for.

Sorry, 06 Titan!
Rooster22 is offline  
post #3 of 4 Old Feb 21st, 2019, 11:31 PM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Joined: Dec 2004
Location: NJ (Philadelphia area)
Posts: 5,990
The drive belt that drives the A/C compressor may be worn or loose . Also the system may be low on refrigerant. If you have a gauge set, check the high/low pressures; with the engine idling and an outside temperature of around 95(F) and Relative humidity of around 50 - 70, the low pressure side should be around 39 - 48 psi, high side around 195 - 245 psi. . If you don't have a gauge set or don't know how to do it, then have an A/C shop do it.

KA-T for life, yo!
rogoman is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old Feb 22nd, 2019, 05:47 PM Thread Starter
NissanForums Newbie
 
Joined: Feb 2019
Posts: 3
Thanks! I'll have to get it checked!
Rooster22 is offline  
Reply

  Nissan Forum > Truck & SUV > Titan & Armada

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW COKE w/ Lime ? LIKE , DISLIKE , HAVENT TRIED , or DONT CARE ? LIUSPEED Off Topic Section 11 Feb 21st, 2005 04:48 PM
havent seen anyone mention this header... raydawg QG18 1.8L Engine 1 Nov 17th, 2004 06:03 PM
I (chuck) havent really said anything lately.. Chuck Forced Induction & Nitrous Oxide 14 Sep 5th, 2004 06:17 PM
Mainly for Myetball and those who havent' seen this!! boost_boy B11/B12/KN13 82-90 chassis 15 May 31st, 2003 08:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome