06 Armada Rear Heater no blows air at all...AC OK - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Nov 25th, 2018, 09:36 PM Thread Starter
NissanForums Newbie
 
Joined: Sep 2014
Posts: 6
06 Armada Rear Heater no blows air at all...AC OK

My NISSAN ARMADA 06 4X4 doesnt blows air in heater position at all for back seats ROOF REAR...FAN is working fine, AC IS OK but when I turn knob to heater doesnt blow any air and rear fan still working...I changed already the rear flap actuator motor...still the same,but manually without the motor do the same i think the flap doesnt go until the end( stock) blocking the air from the heater...Somebody already try to get the rear AC/HEATER assy out to see whats happened or do this job before??..Thanks for any help

pppininfarina is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Nov 27th, 2018, 10:04 AM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Joined: Dec 2004
Location: NJ (Philadelphia area)
Posts: 5,989
Check the fuses. You can download a copy of the Factory Service Manual (FSM) from https://ownersmanuals2.com/. The ATC.PDF section is the one you want to read to diagnose your problem.

KA-T for life, yo!
rogoman is offline  
Reply

  Nissan Forum > Truck & SUV > Titan & Armada

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Nissan Pulsar X1 - Heater blows cold air djsuperersain B14 95-99 chassis 1 Jan 27th, 2016 06:16 PM
Heater/Air Vent Control '05 Blows Floor Only Day-Day B15 2000-2006 7 Nov 24th, 2010 08:36 AM
Heater/AC only blows through window/defog? SaucyTabasco Z32 Chassis 300ZX 5 Dec 19th, 2005 01:48 AM
1994 sentra heater blows cold new94 New Member Forum 2 Jan 10th, 2004 03:30 PM
heater blows cool air dfinley66 B13 91-94 chassis 5 Dec 10th, 2002 12:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome