2010 Armada No Heat L/S - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jul 5th, 2018, 01:23 AM Thread Starter
NissanForums Newbie
 
Joined: Jul 2018
Posts: 3
2010 Armada No Heat L/S

please help. My 2010 Armada has only cold air on driver side. Any ideas what the issue may be? Thx in advance!

Rlad is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jul 5th, 2018, 02:17 PM
NF Mod/Nissan Master Tech
 
smj999smj's Avatar
 
Joined: Jan 2006
Location: Prospect, VA
Posts: 9,199
I would think the most likely cause would be a faulty mode door actuator that controls the air to the passenger side. There should be a self-diagnostic test for the climate control system listed in the factory service manual. Going through the self-diagnostic test would likely be helpful in confirming the faulty actuator. The bad news is that if it is the problem, the dash will likely need to be removed in order to access the actuator. The actuator itself is usually around $35 +/-, but the labor is where the expense lies.
smj999smj is offline  
post #3 of 3 Old Jul 5th, 2018, 10:50 PM Thread Starter
NissanForums Newbie
 
Joined: Jul 2018
Posts: 3
Thank you! Would you share the link to the FSM? I googled it, ended up on the nico club website, but i couldn't access it due to copyright issues. Thx!
Rlad is offline  
Reply

  Nissan Forum > Truck & SUV > Titan & Armada

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 armada se premo1985 Titan & Armada 2 Jul 5th, 2018 10:59 PM
2007 Pathfinder no rear heat and intermittent front heat hefeighteen Pathfinder 6 Jan 4th, 2018 10:38 PM
2010 Armada swifty72 Titan & Armada 0 Nov 24th, 2016 11:24 AM
2010 Nissan Armada Platinum Review Administrator Nissan News 0 Feb 19th, 2010 04:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome