07 Titan AC problem - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old May 3rd, 2018, 04:56 PM Thread Starter
NissanForums Newbie
 
Joined: May 2018
Posts: 1
07 Titan AC problem

Hey guys, wonder if anyone else has had this happen- AC blows hot/cold just fine, but the fan only blows one speed no matter what setting I turn the dial to. Any advice on what this might be?

Jwrin373 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old May 3rd, 2018, 06:09 PM
NissanForums Newbie
 
Joined: Jan 2018
Posts: 4
Blower motor resistor. Should be about $60 from the dealer. Easily found below the dash. Had the same issue on my 2007 Armada (bought used) as soon as I got it. 10 minute fix.

Sent from my SAMSUNG-SM-G890A using Tapatalk
pwgood1 is offline  
post #3 of 3 Old May 3rd, 2018, 06:17 PM
NissanForums Newbie
 
Joined: Jan 2018
Posts: 4
I meant "below the glove box." Here is an image I googled up.

Sent from my SAMSUNG-SM-G890A using Tapatalk
pwgood1 is offline  
Reply

  Nissan Forum > Truck & SUV > Titan & Armada

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2017 Nissan Titan vs Titan XD Review AutoGuide.com Announcements 0 Nov 10th, 2016 10:20 AM
nissan titan exhust muffler problem? louis2387 New Member Forum 0 Dec 12th, 2007 11:34 PM
titan x-band radar detector problem ozzysdad Titan & Armada 1 Jan 6th, 2007 04:55 PM
Is it true that the rotor problem is fixed on Titan and Armada? pest44 Titan & Armada 4 Mar 23rd, 2005 02:30 AM
Looking for Titan owners or people interested in Titan m4ck Titan & Armada 3 Sep 23rd, 2004 07:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome