Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My wipers and washer work fine but not together. When you pull the washer and run it the wipers should swipe a couple of times and mine isn't . Anyone have any ideas why not?
 

·
NF Mod/Nissan Master Tech
2006 Pathfinder LE, 2003 Frontier SVE
Joined
·
10,210 Posts
My wipers and washer work fine but not together. When you pull the washer and run it the wipers should swipe a couple of times and mine isn't . Anyone have any ideas why not?
Stanzas and Altimas have been around for a long time, so providing us with a year for your car would be very helpful! :)
 

·
NF Mod/Nissan Master Tech
2006 Pathfinder LE, 2003 Frontier SVE
Joined
·
10,210 Posts
Well, according to the 2016 Altima factory service manual (should be same or similar to 2017 manual), which you can access @ Nico Club's website, "wiper not linked to washer operation" can be caused by a bad combination switch (wiper and washer switch), harness between combination switch and BCM (Body Control Module) or a bad BCM. For diagnostics, it says to refer to "symptom table" on page BCS-79, which would be in the "Body Control System" section. Then, you pretty much need access to a capable scan tool to continue the diagnostic steps... So much for the "good ol' days" of fixing cars!
 

·
Registered
Joined
·
731 Posts
It's probably a bad combination switch, but you can check it without a scanner by looking at the strobe input to the BCM at the combo switch connector. The washer is on input2, a pink wire on pin 9 of the connector. The switch uses a strobed matrix so you can't just check continuity, but your voltmeter should read a rise in voltage whenever the washer switch is pulled, probably 1~1.5 volts from the base reading. If you don't see any change when you pull it, the switch is bad.


7292
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thank you for the info and time spent looking it up. I took it to the dealer and learned I wasn't giving it long enough to start wiping. My Town and Country started wiping the minute I pushed the washer button. The Altima doesn't it squirts for a few seconds and then start wiping. So I feel dumb, they work normally this was driver error. Thank you again.
 

·
Registered
Joined
·
731 Posts
You're most welcome. Yes, many Nissan washers don't have a check valve to prevent fluid from flowing back into the tank after the washer is used, so the pump has to fill the lines back up before anything comes out. You can actually put an external check valve in the line if it bugs you. Something like this will work fine:

Windshield Washer Check Valve-Washer Pump Valve ACI/Maxair 399004 | eBay

There's a plastic union on most Nissans where the washer hose goes into the cowl, there so the cowl can be removed without disconnecting all the plumbing. You can just replace the union with the check valve, no cutting needed.
 
1 - 7 of 7 Posts
Top