Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
im havin problems with my water shooters on my hood....sry i dont know the proper name for them....but anyway.....at first my right side was shootin fine but my left wasnt so i assumed it was clogged...so i took it off and unclogged it by stickin needle in there...also a small spring came out of there and i couldnt put it back in so i didnt worry about it....so i put the water shooter back on there and now neither side works....so if i get muddy water on my windshield and wipe it that shit will smear and i will crash my newly bought 240.....plz help....
 

·
KA24DET
Joined
·
1,000 Posts
cwrr226 said:
im havin problems with my water shooters on my hood....sry i dont know the proper name for them....but anyway.....at first my right side was shootin fine but my left wasnt so i assumed it was clogged...so i took it off and unclogged it by stickin needle in there...also a small spring came out of there and i couldnt put it back in so i didnt worry about it....so i put the water shooter back on there and now neither side works....so if i get muddy water on my windshield and wipe it that shit will smear and i will crash my newly bought 240.....plz help....
Replace the sprayers.
 

·
so close to turbo...
Joined
·
925 Posts
no no you dont need new sprayers.....well unless you screwed it up with the needle...anyways to unclog them heres what you do.
pop the hood and disconnect the rubber tubes going to those sprayers. its 2 small lines, kinda look like vaccuum lines sorta. now just take an air chuck and put it in front of the sprayers on top of the hood and blast air through them. do not spray from the other side though.

and to readjust, that silver center piece moves very freely, you dont need any needles to point it or anything just push it
 

·
Tarmac Terrorist
Joined
·
272 Posts
Kelso said:
no no you dont need new sprayers.....well unless you screwed it up with the needle...anyways to unclog them heres what you do.
pop the hood and disconnect the rubber tubes going to those sprayers. its 2 small lines, kinda look like vaccuum lines sorta. now just take an air chuck and put it in front of the sprayers on top of the hood and blast air through them. do not spray from the other side though.

and to readjust, that silver center piece moves very freely, you dont need any needles to point it or anything just push it
Washer Fluid Pump might be blown out too...
Check that if un clogging them does not work!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #5
a :newbie: answer to my problem

well guys they arent clogged and they arent pinched. i follow some cord from the tube under my passenger fender and i noticed that there were 2 small metal rods that were poked out of the some square....i didnt know whut to do but i just left them there and when i showed a friend his dumbass broke on of the rods.......so i think that was the answer to my problem.. those rods needed to go in the box but i have no clue whut thouse rods were for and how they got out....and where can i get another since my friend broke one off.....sry i know....i try and post pics of whut im talkin bout if u dont undastand let me know....
 

·
Registered
Joined
·
189 Posts
lol yea having a littel trouble picturing this. Windshield wiper fluid system isnt to complicated. Should be just a pump going from the resevuar to the sprayers on the hood... You either have a clog, cut line, or bad pump... Or maybe out of fluid.. lol
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
Chris90FB240sx said:
lol yea having a littel trouble picturing this. Windshield wiper fluid system isnt to complicated. Should be just a pump going from the resevuar to the sprayers on the hood... You either have a clog, cut line, or bad pump... Or maybe out of fluid.. lol
lol...yea i know had a feeling that it would be hard for yall 2 undastand....i know im not outta fluid....becuz its topped off.....ill post some pics soon enuff
 
1 - 7 of 7 Posts
Top