Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I bought a new Quest 2004 in August 2003. It has 34000kms and I am satisfied with the quality and the overall performance except for the window windsheild washer. When the WW washer is activated, the liquid flow is obstructed by the wipers' arms so very little of the liquid reach the window. I have referred the problem to my concessionnaire who has done his best to improve the situation. There is an amilioration but it is not satisfactory. It would appear that this is a design defect.
I have Emailed Nissan with that defect last month, no reply to date.
I am residing in Montreal area and have to do a lot of driving regurlarly. When the pavement is wet and calcium has been spread driving become very hazardous.
I have met an unknown individual recently who is also driving a Quest. He reported that he has used a 4 liter ww liquid to drive 35 kms and has to drive the last 10kms in Montreal City without ww liquid as the content was empty.
Who else is experiencing this problem? Has somebody have corrected it satisfactorily?[email protected] .
 

·
Banned
Joined
·
4,308 Posts
i know what you mean, my moms car has that problem on the rear. some cars have the fluid nozle on the wiper arm its self, maybe you could find one (mostly dodges i think) and some hom fit it onto your wiper arm, then just splice the fluid line in. i hope that helps some.

wlecome to nf.com :cheers:
 

·
Banned
Joined
·
4,308 Posts
i dont think thats the problem, on our car (rear window) the nozzle is above the window (its a wagon) and so is the wiper blade, so when you push the fluid button is sprays the wiper! not the window, then the wiper moves and the fluid trickles down a little and does nothing but smear it up. granted its a ford and i expact that kind of crap but imports are normaly more thought out.
(i have aimed it and if you aim it out any farther it will just spray the road)


^thats what my problem is, and putting a nozzle on the wiper blade would solve it, im thinking this is close to his problem as well.
it was bigger when i made it :(
 

·
Registered
Joined
·
2 Posts
05 Murano rear window washer problems

I have a similar problem with my '05 Murano. As far as I know the rear window washer has never worked (I purchased the vehicle with 6,000 miles already on it). I hear a whirring sound when I push the lever for the rear window washer, which sounds like the pump motor running, but no fluid comes out. I have recently topped of the washer fluid reservoir. The front washer works fine. Is there a separate reservoir for the rear window? The owner's manual provides little information. I assume that the fluid comes from an opening on the wiper itself, since I can't see any other nozzle or opening on or around the rear window.

Have other Murano owners had this problem?

Thanks in advance for any help.
 
1 - 5 of 5 Posts
Top