Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I purchased a 95 Pathy 2wd 5 speed recently and the person that owned it before me said that he had never change the timing belt..So i changed the timing belt,water pump and thermostat..Well in the process of changing everything I broke what looks like some kind of sensor that attatches to the top of the top radiator hose..There is actually 2 sensors that attatch to the metal piece that attatches to the top radiator hose..The one that i broke is closest to the area where the metal piece bolts into the thermostat housing..I decided to test drive and i noticed that the temp guage was reading more than 3/4 of the way to the H..I turned on the heat and it was blowing hot air for a while then is started blowing cool air but the temp guage was 3/4 up..My questions are would the broken sensor cuase my temp guage to read hot.One other thing, does this sensor having anything to do with the clutch fan? The clutch fan did not seem to pull much air thru the radiator..Does the sensor control the clutch fan to?Any advice would be greatly appreciated..ED
 

·
Moderator
Joined
·
3,553 Posts
Apparently you broke the temp switch for the dash gauge. Replace it and it should be all good. The fan clutch is entirely mechanical, nothing controls it except heat. When it's hot it should lock up, when it's cold it should spin free.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the reply.I will change the temp switch and temp sensor on sunday.But what about it blowing hot air then it blowing cool air with the heat turned on?Strange!!Thanks again. Ed
 
1 - 3 of 3 Posts
Top