Nissan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
319 Posts
Discussion Starter · #1 · (Edited)
Well turns out all my bull crap about main bearings and valves is totally out the window. Seems one of my belts is whinning, but i neglected to open the hood, but with the hood covering it, sounds like the valves oddly enough. Dunno which belt or why it would be whinning considering i just had my mechanic take the whole front end off to get to the timing guides, any help? THe belts don't seem to have cracks or anything but not 100% positive. Also, i did my usual maintence of things, hoping that this god forsakin smell would dissappear. Well I've pinpointed that its coming from behind the entire motor and low, some sort of burning or something, its sick anyways. I don't know why my tranny would smell, especially when I just checked my leaks and stuff in Neutral. please, help, this is driving me crazy! Also, i noticed that the gasket on my #4 injector is starting to peel away. What all has to be done to get at the injectors? Arn't these puppies pretty expensive too?
 

·
Registered
Joined
·
347 Posts
little240boy said:
Well turns out all my bull crap about main bearings and valves is totally out the window. Seems one of my belts is whinning, but i neglected to open the hood, but with the hood covering it, sounds like the valves oddly enough. Dunno which belt or why it would be whinning considering i just had my mechanic take the whole front end off to get to the timing guides, any help? THe belts don't seem to have cracks or anything but not 100% positive. Also, i did my usual maintence of things, hoping that this god forsakin smell would dissappear. Well I've pinpointed that its coming from behind the entire motor and low, some sort of burning or something, its sick anyways. I don't know why my tranny would smell, especially when I just checked my leaks and stuff in Neutral. please, help, this is driving me crazy! Also, i noticed that the gasket on my #4 injector is starting to peel away. What all has to be done to get at the injectors? Arn't these puppies pretty expensive too?
Sounds like there is alot of prior poor maintainance and the 240sx was neglected.
The clutch oil is possibly being sucked out from the top of the tranny at the shifter and blowing on to the exhaust pipe. The injectors are cheap for OEM rebuilts. and easy to get to. Just follow the FSM for taking pressure off the fuel system.
And take it back to your Mech and have him/her adjust the belt tensions correctly.
Just some Ideas
 

·
KA24DET
Joined
·
1,000 Posts
spec240sx said:
And take it back to your Mech and have him/her adjust the belt tensions correctly.
Just some Ideas
Harhar, the best $10 I ever spent was a belt tensioner. Invest!
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #4 ·
how would I check to see in clutch oil is being sucked out of the tranny? What can I do about it. When I got my car back from getting the clutch awhile ago, I noticed that he missed tightening down my 2 top bolts on my bell housing (what a retard really, nice honest guy but still). Could it have something to do with that?
 

·
Tarmac Terrorist
Joined
·
272 Posts
little240boy said:
how would I check to see in clutch oil is being sucked out of the tranny? What can I do about it. When I got my car back from getting the clutch awhile ago, I noticed that he missed tightening down my 2 top bolts on my bell housing (what a retard really, nice honest guy but still). Could it have something to do with that?
If the top bolts on the bell housing were not torqued to proper specs, as well as the rest of the bolts there is a chance that the main seal may have become damaged, and that is where the fluid is leaking out...in order to fix that you may have to take your tranny off again...this happened to me with a 1991 Ford Aerostar (My first Vehicle :loser: ). The seal, or gasket shouldn't be too expensive either, local auto parts stores should stock them, or be able to order them in. :thumbup:
 
1 - 5 of 5 Posts
Top