Nissan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
hey whats up

Ok i have my 91TT in storage and havnt started it in about a month. So i strted it today( just turned it on and dont rev it), and it was makin this clickin/ticking sound on the left side of the engine. When the temp gauge got warmer the clickin was wost and then a weird knockin sound started happenin in the back of the engine. I have no idea what it could be. Any ideas
So i picked up some sea foam today-guy at autozone said it might help-. Im thinkin about pourin half in the gas tank and half were the oil goes. Anyone us this stuff? Im hopin it might help
Any help would be great

Thanks
 

·
Banned
Joined
·
3,554 Posts
Sounds like ticking lifters. But should've gotten better when it got warm. I would go take it for a drive.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
SKD_Tech said:
Sounds like ticking lifters. But should've gotten better when it got warm. I would go take it for a drive.
would that mess it up worse?
 

·
Icy Hot Stunta
Joined
·
2,366 Posts
300zxowns said:
hey whats up

Ok i have my 91TT in storage and havnt started it in about a month. So i strted it today( just turned it on and dont rev it), and it was makin this clickin/ticking sound on the left side of the engine. When the temp gauge got warmer the clickin was wost and then a weird knockin sound started happenin in the back of the engine. I have no idea what it could be. Any ideas
So i picked up some sea foam today-guy at autozone said it might help-. Im thinkin about pourin half in the gas tank and half were the oil goes. Anyone us this stuff? Im hopin it might help
Any help would be great

Thanks
Did you check your oil level? If the oil level is ok and if the car has not been running for a long time, and the noise is coming from the valvecover, it could be a collapseds HLA. It might take 20-30 minutes of running to get it to pump up again.

If its from the front of the engine, it might be a bad VTC. You need to change the spring in it.

Don't put weird addtives in your motor.
 

·
Power FC Z32
Joined
·
2,147 Posts
morepower2 said:
Did you check your oil level? If the oil level is ok and if the car has not been running for a long time, and the noise is coming from the valvecover, it could be a collapseds HLA. It might take 20-30 minutes of running to get it to pump up again.

If its from the front of the engine, it might be a bad VTC. You need to change the spring in it.

Don't put weird addtives in your motor.
Just like what Mike said! :)
 

·
Registered
Joined
·
64 Posts
Discussion Starter #6
morepower2 said:
Did you check your oil level? If the oil level is ok and if the car has not been running for a long time, and the noise is coming from the valvecover, it could be a collapseds HLA. It might take 20-30 minutes of running to get it to pump up again.

If its from the front of the engine, it might be a bad VTC. You need to change the spring in it.

Don't put weird addtives in your motor.

The oil level is good and the noise is in the back off the engine. So would sea foam be a weird addtive???
 

·
Registered
Joined
·
64 Posts
Discussion Starter #8
JAMESZ said:
Is it knocking? As in engine knock?
Um yea i think so....but not to sure
 

·
Banned
Joined
·
3,554 Posts
Knock at idle? There's gotta be something seriously wrong.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #11
SKD_Tech said:
Knock at idle? There's gotta be something seriously wrong.
Ok so i just dumped a bottle of sea foam in and left it runnin for about an hour. Seems to be doin ok now. tickin is gone
 

·
Banned
Joined
·
3,554 Posts
300zxowns said:
Ok so i just dumped a bottle of sea foam in and left it runnin for about an hour. Seems to be doin ok now. tickin is gone
Nice. Hopefully it'll stay gone.
 
1 - 12 of 12 Posts
Top