Nissan Forum banner

1 - 20 of 28 Posts

·
Banned
Joined
·
809 Posts
Discussion Starter #1
Hey, I have terrible news about halo's...

They blow your stock fuse after about a month.. I ran mine for a month, and it blew.. then i bought a new one, and it blew again... beware.. these fuses are 20bucks a pop.. and you HAVE to buy them from a nissan dealer... its FS75A.. something like that.
 

·
DNE's VZR Conversion
Joined
·
6,079 Posts
i doubt you need to buy them from the dealership. im pretty sure pep boys , autozone , kragen has them. Just buy the one with a little thicker wire inside you should be ok. My friend 95 civic kept blowing fuses we jes upgraded to one step higher on the fuse and it all good now. try that.
 

·
in^3,N20,RPM,PSI
Joined
·
4,652 Posts
LIUSPEED said:
i doubt you need to buy them from the dealership. im pretty sure pep boys , autozone , kragen has them. Just buy the one with a little thicker wire inside you should be ok. My friend 95 civic kept blowing fuses we jes upgraded to one step higher on the fuse and it all good now. try that.
isn't that a little unsafe?
 

·
DNE's VZR Conversion
Joined
·
6,079 Posts
no.. it just the wire in the fuse it a little thicker that about it. everything is the same.
 

·
DNE's VZR Conversion
Joined
·
6,079 Posts
i think so.. cuz we just bought the fuse a lil higher as what the KRAGEN people told us. and now nothing went wrong on his lil civic.
 

·
Red line chaser
Joined
·
814 Posts
Have seen this happen a few times when installing projectors.
Please check your grounds. The better your grounds, the less chance of you popping fuses. Scrape away all paint to bare metal to a good grounding point. All should be okay afterwards. Have had these for about a month and a half w/ no problems.
 
M

·
Guest
Joined
·
0 Posts
no low beams

ok.......i blew the batt fuse when wiring the halo projectors up......fixed that and checked grounds....all show OK......still have no low beams.

any ideas??
 
M

·
Guest
Joined
·
0 Posts
no low

Well i dont even get that.......when i hit highbeam everything lights....low beam all i get is halo and markers and fogs when that switch is on......but i get nothing out of the outside bulbs when the switch is any positions but high beam. Im thinking its a relay or internal wiring in the headlight assembly.....b/c all grounds, connectors and hookups are ok. any ideas??
 

·
Banned
Joined
·
1,531 Posts
Ya know....I've had mine for almost three months now and I haven't had a problem with them AT ALL. No bulb problems, no wiring issues, no fuses blown. Problem is, I can't really remember HOW I installed them.

I just know it took me ALL day. Being slow, I guess I did something right. I actually went almost by NPM's write-up. Good luck with the rest of yall.
 

·
Banned
Joined
·
809 Posts
Discussion Starter #16
the whole problem is, the wireing harness that is provided..... its not made for our cars, thus so, you have to make your own. get some 9003 female adapters, and 9004 male adapters, splice, and it plugs i just like a 9004 light bulb... screw all that relay and fuse crap. much easier this way
 
M

·
Guest
Joined
·
0 Posts
well if you dont utilize the relays and such in the projector wiring the halos are shitty looking.....all dim and such.......anyone have any real ideas about no low beams using the projector wiring???
 
M

·
Guest
Joined
·
0 Posts
correction

not the halos....the low and high beams.......hence why they supply a relay!!!!
 

·
Registered
Joined
·
37 Posts
im so upset lol to see all these problems, i just bought a pair, im about to install em, i don't want them to look crappy, i don't want to be replacing fuses n stuff...

What do you people Recommend is the absolute best way to install these things , use the wiring harness and relays and crap?? or do like the other guy said and make my own?? i want the halo to be as bright as possible, i need low beams too lol

lemme kno

:cool:
 
M

·
Guest
Joined
·
0 Posts
ok....my opinion

Even though it didnt work for me when i did it......do it with the wiring harness. ive got the instructions from matrixracing so if you need them pm me......ill send you the same emails i got from them......there are a few things i did differently then their plans......buy a 9003 female plug to solder where the stock 9004 bulb goes. use the harness, make sure you disconnect the battery when you solder the connector to the stock wiring. Then install the harness and make sure you have good grounds.....thats important for the brightness of the bulbs. Use the matrixracing install instructions instead of the nissanperformance mag ones.....like i did which i wish i hadnt!!!!! then you wont have to remove the grille brackets and your grille will be tight and also you can convert them back easier.

Thats my opinion on projectors. Ive installed a few sets and none of them blew a fuse in a month or so.....the ones that i had most trouble with were mine and i did them not too long ago b/c matrixracing never sent me the pics for install so it was a lot harder then the hondas and such (which i installed on friends car)

Thats my 2 cents.....take it or leave it, its up to you.
 
1 - 20 of 28 Posts
Top