Nissan Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Last week during a strong rain, I pulled out and slipped a tad. My ABS activated and that was all that happened. It has been a week now and this issue has persisted. When I drive for about 50 or so feat, all of the lights relating to the brake system come on.

VDC wont turn back on, I have disconnected the battery to reset the computer, I have added brake fluid, I have checked the fuses that the manual says are related to the ABS and VDC.

I have gotten codes read and they say that my right rear wheel speed sensor and abs actuator have had failures and that I am out of alignment. I have disconnected and reconnected the speed sensor and nothing has worked.

Does anyone else have any tips on how to fix this stuck VDC light and brake system before I start throwing parts at it.

Also, does anyone know if there are rear speed sensors for less than $80? I cannot find any places selling this part for less but $80 for a single cord and plug seems insane.
 

·
Registered
Joined
·
1,247 Posts
Dunno your vehicle details, but the actuators are all inside the ABS unit and it's very unlikely that an actuator and speed sensor would fail at the same time. Chances are you've just had a sensor failure. To find the cheapest part, use the Nissan part number to search and not the make/model/year. You can get that from NissanPartsDeal.com by entering your VIN number. NPD uses the exact same database and diagrams as Nissan DPC, so you can be sure the p/n that shows up is the right one for your ride. Then you can use that p/n to search Rock Auto, eBay, Google, Kijiijii or anyplace else.
 
1 - 2 of 2 Posts
Top