Nissan Forum banner
1 - 2 of 2 Posts

· Former SuperMod
Joined
·
1,600 Posts
Off the top of my head (I'm not engine guru either), it could be that the engine is lacking something... fluids, spark, or oxygen. When you said it idled hard, first thing I thought was clogged hose/clogged fuel filter/improperly gapped spark plug. BUT if it just came on all-of-a-sudden, I would rule out the plug. If you checked your oil and that seems to be fine, good. When you rev it up in neutral does it shudder? I don't think a poor muffler would cause a car to idle rough... at least not to what you are saying. Does it sound like the car is gonna die? Or is it just not smooth like normal? Give us an update on the condition of the rough idle so we can further assist you. Good luck,
 

· Former SuperMod
Joined
·
1,600 Posts
This is going out on a limb but...

Did you just recently fill up with a tank of gas? Perhaps you got some poor quality fuel.

I wish I could see or hear the engine, because it is difficult to diagnose. Do you hear it pinging? Had the ecu been reset recently? Could any water from rain or car wash gotten into any electrical components like plugs, wires, cap, or rotor? Check the O2 sensor on the exhaust manifold. You don't have ODBII on your Classic so it's just the one oxygen sensor. Hopefully others will chime in and give their opinions...
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top