Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
so i gave my 02 frontier its first tune up at 60K. mainly becuase the fluids and what nots have been in their for 6+ years and i want the truck to last me forever. The fluids were all black and needed to be changed, changed the fuel filter, repacked the front bearings and everything came out great and worked so much better. I changed the plugs, wires, cap, and rotor with O.E. recomended replacements becuase my truck was real hesitant and strained to do some pulling. The plugs were pretty burnt up. For about a 2 weeks they worked great and there was a huge difference threw out the power band. Now the truck is hesitant again and i can feel a vibration when it idles. I made sure the plugs are in and the wires are on properly. It has not thrown codes yet and I pulled the some of the plugs and they seem fine. Anyone have some ideas before I take it to the dealer and pay 11 million dollars for them to look at?
 

·
Registered
Joined
·
1,290 Posts
so i gave my 02 frontier its first tune up at 60K. mainly becuase the fluids and what nots have been in their for 6+ years and i want the truck to last me forever. The fluids were all black and needed to be changed, changed the fuel filter, repacked the front bearings and everything came out great and worked so much better. I changed the plugs, wires, cap, and rotor with O.E. recomended replacements becuase my truck was real hesitant and strained to do some pulling. The plugs were pretty burnt up. For about a 2 weeks they worked great and there was a huge difference threw out the power band. Now the truck is hesitant again and i can feel a vibration when it idles. I made sure the plugs are in and the wires are on properly. It has not thrown codes yet and I pulled the some of the plugs and they seem fine. Anyone have some ideas before I take it to the dealer and pay 11 million dollars for them to look at?
You have the fuel filter in the correct orientation (flow of fuel matches arrow)?

Is the distributor tight (the housing can't rotate freely to change timing)?

Air filter? PCV filter (if equipped)? PCV (if equipped)?

Fan clutch and other accessory pulleys moving freely?

Cracked or disconnected vacuum lines?

Bad gas?

Can't really think of anything else.
 

·
Registered
Joined
·
315 Posts
You have the fuel filter in the correct orientation (flow of fuel matches arrow)?

Is the distributor tight (the housing can't rotate freely to change timing)?

Air filter? PCV filter (if equipped)? PCV (if equipped)?

Fan clutch and other accessory pulleys moving freely?

Cracked or disconnected vacuum lines?

Bad gas?

Can't really think of anything else.
Could be that 10% Ethanol fuel we've been mandated to run.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #4
i thought i saw a thread around here with some people having problems. I checked everything. I spent 2 hours yesterday puling plugs, checking hoses, pullys and belts, etc and checking everything. I have been noticing some upper motor rattleing when i first start it up. it sounds like valve noise, almost like a fluttering, and when the car is idle i can hear it too, not as bad as piston slap but it sounds as repetious.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #5
bump and stil having vibrations, anyone try putting 89 or 93 intheior truck to see if it makes the diff, i just aint got the $$$ to do it
 
1 - 5 of 5 Posts
Top