Nissan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1 (Edited)
bb901841f973 on Flickr - Photo Sharing!

ff76905d57bc on Flickr - Photo Sharing!

I tried to fix this thing when I got the car a couple of years ago.
I first had a mechanic try replacing the speed sensor since I got a 94' with electric speedometer. That didn't work so I returned the $70 part. I then bought a replacement gauge cluster and installed it. That also failed to correct the problem so I put the original back in since it was nicer/in better shape.

The pictures above are the "gear" that Ive been told records the speed from the transmission and sends it to the speedometer. From the pictures and holding it in my hand, it seems to work just fine. This is the last recommended area to look at. Does anyone see anything wrong with it? and if not, what else could be causing this problem?

BTW, the speedometer stopped working a 12K miles so it was a failure that occured early in the cars life, WAY before I had it. Also no odometer or cruise control function.
 

·
Registered
Joined
·
22 Posts
my speed sensor is bad as well, it works when spinning with a drill but in the tranny it doesnt work however my gear is worn an shaped like a half moon yours still looks in good shape it looks straight?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
my speed sensor is bad as well, it works when spinning with a drill but in the tranny it doesnt work however my gear is worn an shaped like a half moon yours still looks in good shape it looks straight?
yes, the gear appears to be in perfect condition. Not any broken/rough edges or anything. If yours is shaped like a half moon, thats quite alot of damage.

Can you see if the gear on the tailshaft is okay?
Im sorry, I dont understand your question. Do you mean that there is another speed sensor on the rear axle? This speed sensor in my pictures is in the transmission.
 

·
Registered
Joined
·
791 Posts
If you look in the hole the speed sensor came out of you should see the gear on the tail shaft that turns it. See if there's anything wrong with it like teeth missing or loose on the shaft.
 

·
Registered
Joined
·
82 Posts
well, you should download the service manual of ur car, then check about speedometer procedure for not good working condition. The Service Manual will tell you to probably mesure the resistence in between the pins of the speed sensor changes when you spin the gear, also another sets of checking ups in order to test other equipament. Do not replace every sistem before doing it.

I hope this was helpfull.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
If you look in the hole the speed sensor came out of you should see the gear on the tail shaft that turns it. See if there's anything wrong with it like teeth missing or loose on the shaft.
I dont think there is any way I could look in there without a small camera w/ light. I had to take it out nearly blind because its hard to see (though pretty easy to get to). Could I try sticking my finger in there (if its long enough) and maybe feeling around for jagged gear edges?

well, you should download the service manual of ur car, then check about speedometer procedure for not good working condition. The Service Manual will tell you to probably mesure the resistence in between the pins of the speed sensor changes when you spin the gear, also another sets of checking ups in order to test other equipament. Do not replace every sistem before doing it.

I hope this was helpfull.
do you know where I could download it at? Is it on this site somewhere?
Thank you.
 

·
Registered
Joined
·
22 Posts
spedo

drewi have the factory servic manual for a ga16de but the files are huge
we just have to figure out a way to get it to you
 

·
Registered
Joined
·
485 Posts
Put it on thepiratebay.org as a torrent.
 
1 - 10 of 10 Posts
Top