Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
547 Posts
Discussion Starter #1
Alright, I posted in the A/F Ratio thread and a mod. told me to make a new thread for my question, so here it goes. I had a 1/4 tank of gas Monday of this week. I then filled up with the same ol' same ol' 87 octance unleaded. Now my car feels like it bogs down and drops RPM's really really fast back down to idle in-between shifts. It feels like it's under some strain, almost like the AC is on. It does it in-between every shift when cold, and sometimes when the car is warm. Does anyone have any idea what it may be? I don't know what RPM's it's dropping to and from since I don't have a tach. Hopefully after this weekend though. Any thoughts to make me think what it MIGHT be, I would give much thanks.
 

·
Registered
Joined
·
393 Posts
just a stab in the dark...... sorry. but is it only when you shift? cuz if it feels a lil more sluggish all the time, it could be your fuel filter?
 

·
Registered
Joined
·
547 Posts
Discussion Starter #3
really it only does it when I shift. But I talked to my dad and he said just throw in some Fuel Injection Cleaner and see if that does it a little better. He said that there's a chance some water may be in the gas since it's been raining here for the past week. He sounded pretty damn confident when he told me, but I'll see if it works. And you mentioned the Fuel Filter...maybe Fuel Inj. Cleaner would clean it a bit just incase. I'll let you know. Thanks!
 
1 - 3 of 3 Posts
Top