Nissan Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
5 Posts
Congratulations on your new ride.

I have a little over 3K on mine now and love it...I'm watching my oil temps closely as the oil is running hot with spirited driving.

As I understand it, there is a service bulletin out regarding using ester oil (a Penzoil product) so I'd suggest you check into that with your dealer.

It's very clear, however, that for anything other than "normal" driving, these cars need an engine oil cooler and possible a transmission cooler as well if you have the 7AT.
 

·
Registered
Joined
·
2 Posts
Congratulations on your new ride.

I have a little over 3K on mine now and love it...I'm watching my oil temps closely as the oil is running hot with spirited driving.

As I understand it, there is a service bulletin out regarding using ester oil (a Penzoil product) so I'd suggest you check into that with your dealer.

It's very clear, however, that for anything other than "normal" driving, these cars need an engine oil cooler and possible a transmission cooler as well if you have the 7AT.
Any suggestions on an oil cooler (manufacturer, etc)?
Ron
 

·
Registered
Joined
·
5 Posts
I'm waiting on NISMO to make one available - I believe the oil cooler already exists but just hasn't been made available for the U.S. yet.

Other than that, I don't have any specific suggestions although I'm sure that there are oil coolers out there that would work well.
 

·
Registered
Joined
·
13 Posts
Picked mine up on March 21st. Got a little over 2k miles on it. Loving the look of the car, looks mean just sitting there.

I haven't seen too many of them on the streets here in Dallas. I think I can count on one hand the number of times I've seen another one on the road.

Mine had to be shipped in from NM because none of the locals had the model I wanted(Base with Sport package).

So far no major problems *knock on wood* Had to replace the drivers rear tire last week due to THREE nails in it. How I managed that I have no idea. This morning I awoke to a dead battery, not sure how that happened. Think I may have left the door open and the interior light drained the battery *shrug*

Biggest issue with the car so far is the radio. I didn't get the upgraded interior, so I got the base 4 speaker radio. When I fade it all the way to the rear, I get nothing. Turns out the 4speaker is 2dash, 2door; not 2front 2rear. Think the audio might be the first thing I go about upgrading.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top