Nissan Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
ok so i own a 97 nissan sentra gxe 4 door automatic 1.6 has 35k(grandmas car from florida (inherited)) and i only get about 18-19 mpg and im about 90% high way driving(no joke live a block from an on ramp work a block from an off ramp) have had it for about a year now

i was wondering what are some of the basic things i could do to get this mpg's up some of my stupid ideas were ecu being that it was florida born and now gets used as a part time sled in minnesota, checked the power steering to make sure no binding was occuring, had a tranny flush, replaced air filter, and basically have run out of ideas accept some engine cleaner but i dont think i would see 10 mpg's different from that(might be wrong), and my last was 30k tune up but once again i dont belive that tune up would put my gas milage back

let me know what ideas are out there so i can try not to trade it in because at this rate i might as well have a v8 titan
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,240 Posts
Ideas.
get the ECU read for codes, the light doesn't always come on.
If no codes check the Ht leads, cap and rotor
Replace the O2 sensor
check the coolant temp sensor and Air temp sensors.
If it really is this bad take it to a rolling road and get a few pulls done with a Wide band O2 sensor, i think it running very rich.
 

·
Registered
Joined
·
505 Posts
ok so i own a 97 nissan sentra gxe 4 door automatic 1.6 has 35k(grandmas car from florida (inherited)) and i only get about 18-19 mpg and im about 90% high way driving(no joke live a block from an on ramp work a block from an off ramp) have had it for about a year now

i was wondering what are some of the basic things i could do to get this mpg's up some of my stupid ideas were ecu being that it was florida born and now gets used as a part time sled in minnesota, checked the power steering to make sure no binding was occuring, had a tranny flush, replaced air filter, and basically have run out of ideas accept some engine cleaner but i dont think i would see 10 mpg's different from that(might be wrong), and my last was 30k tune up but once again i dont belive that tune up would put my gas milage back

let me know what ideas are out there so i can try not to trade it in because at this rate i might as well have a v8 titan
I am actually started to notice the same issue. Only got about 200 miles on my last tank of gas. I used to see over 300. Maybe it's the weather? I have new plugs, but haven't change the cap, rotor, yet. Might do that along with a fuel filter. I am also going to try a different gas station. Will let you know my results.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
thanks for the ideas im going to check all those out once i get my car back just had the front main seal go sweet life is 185 for that job a bad price from a good shop?
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,240 Posts
well i can tell you it took me some time and was a pain, so i guess if their labor rate is $60 70 or so that's ok.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,240 Posts
so you are saying he overpaid !!
And I took to long!! :)
 

·
Registered
Joined
·
20 Posts
Discussion Starter #9
yah i overpaid thats fine though i was at work it was done by the time i got off work and me i have no clue how the hell to fix a car, not that im stupid i just was never brought up doing that so i have no tools or anything, i once made an afternoon to replace bulbs in the head lamp pretty sad but self learning
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,240 Posts
Well we all learnt that way at some point....
and we all have our repairs that didnt go so well...
 

·
How far can I take it?
Joined
·
421 Posts
hi there. I guess this is the right place to ask. I think I can improve on my mpg @ 20+mpg right now with about 70% highway. I am at about 10mpg off my expectation with having old car and engine. The car runs great right now with all ther repairs that I did. I asking for some help in places that I probably made mistakes? or missed? So far, what I have fixed on the car since I got it 14 months ago:
replaced egr valve -12 months ago
replaced passenger cv axle - 12 months ago
plugs - 12 months ago (ngk platinum) checked fine 2 months ago
wires cap rotor and the ignition distributor 3 months ago.
fuel filter - 8 months ago
tranny oil changed twice to clear up the fluid 3 months ago - with 1 bottle of lucas tranny fluid additive
adjusted timing (was on 5deg) a week ago
repalced maf sensor, air temp sensor, iacv 1 month ago
cleaned tb 12 months ago
regular oil change and frequent injector cleaners every 4 fill-ups
drained coolant and replaced with what I had at home (my family's dump site for things they didn't want) not sure how old the coolant I had at home though. But they were very clean complared to what I draing. And yes, I bled the system. I missed unscrewing the engine drain plug because it wont come out and not able to unscrew the temp sensor as well.
chain tension is bad, have chain slapping sound (been putting it off)
(all sensor and valve replacements were due to cel codes)

my car is a 95 gxe a/t, 16" rims 205 width 50series tires, KNN intake air filter (no ram, not cold air), headers, 145k mi., tire pressure is good and alignment (Been putting of replacement of suspension due to lack of funds).
No CEL codes right now although the vss keeps popping up every now and then but goes away after several cycles. No prob with speedometers odometers trip meter.

The car's power is how I expect a 16cc 16valve twin cam should perform. Its running quick and you can feel that vts kick in. I drive hard when I get a chance on the highways and I do have a large tool box in the trunk with an alligator jack in it and of course tools. But I dont think any of those things would reduce my mpg by 10mi? At this rate its consuming gas as much as my brother's honda pilot. But I think I can outrace his suv in a quarter mile :)

sorry for the long post
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,240 Posts
This generation of Auto subtracts 3 -5 mpg from manual

My 97 GXE manual was consistent 28 -32 on 200 mile highway in Texas at 70 -85 mph with 195/50/15 tires.

in town 22- 26 mpg heavy traffic. Think my VTC may have been stuck in high. revved all the way to cut out, no retard at 6000 -6500 rpm as its supposed to do.

mileage was worse than new by 15% at 100k, tires, speed and age, nothing much changed except plugs.

Replace your first O2 sensor, it was good for +10% on my Legacy at 100k miles.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,240 Posts
and your speedo and ODO will be off with those tires, so its not as bad as you think.....

I make it over 6%, so you are 6% faster and going 6 % further than you think....
 

·
How far can I take it?
Joined
·
421 Posts
you're right about the odo. When I went to VA (about 240mi) my gps had a different reading. about 20mi more. Based on your numbers and the depreciation of the car, Im still off. But I can live with what I have right now than what I had before- Same MPG with 0-60mph in about 3 years!!!
 

·
How far can I take it?
Joined
·
421 Posts
Hi guys, Im back on this thread for more advice. I've not been able to change the O2 sensor since the previouse owner changed it before he sold the car to me. And to add to the list above, I replaced the cat just after the posting.
I've been on a roller coaster engine performance. Almost everytime I fix something on the car to improve mpg, it does improve somewhat but in about after 70 miles it goes back to its guzzling ways. 12mpg is really awful.
I just recently replaced my upper chain tensioner then I checked my timing and rattled my air temp sensor. Viola! seemed to made a difference - about 80 miles on the first quarter of a full tank - it ended at 165 miles when it consumed 3/4 tank of gas. about 7.7 gallons. around 21mpg. about 120mil highway.
Another thing, the engine power is also inconsistent, some days, or conditions maybe, it will run great, downshifting properly, others - pedal to the floor but it does not down shift, no pull whatsoever.
What could be the problem?
oh yeah, CEL is on, have not been able to get the code, but I am assuming its the vss again even with the spedomerter working fine.
How do you test a sensor? Like the air temp sensor, I want to know if its working or not. I replaced it as adviced by the mechanic at nissan. This could be my problem

Thanks.
 

·
Registered
Joined
·
229 Posts
hmmm... the trouble code could tell you something useful. I had the vss code a couple years ago, and it wasn't the vss. it was the wiring in the instrument cluster that had a short and didn't feed the ECU the VSS signal.
My vss code only came on intermittently, but when it did, it was aweful! The car performance just died. I couldn't hardly climb hills on the interstate in 3rd gear!

Check the codes, and get back to us.
 

·
Registered
Joined
·
47 Posts
We have quite a bit of B14s out here and the most common complaint is the actual throttle body. There is some adjustment part of it that creates havoc with driveability and gas mileage. You could check that out.
 

·
How far can I take it?
Joined
·
421 Posts
finally found time and the autozone that had a code reader. As expected, P0500, vss. same thing. The guy printed out the reading and it suggests several things to check. Same things as discussed here in this forum.

The light is still on although I was able to find time last Sunday to take out the cluster, pull out all wires to clean it up. What I did not have was the electronic cleaner (deoxidizer) to make sure all contacts are cleaned. I used wd40 and q-tips. pulled out a bit the metal contacts from the plugs and tightened the screws. The car does seem to be running better. It feels lighter.

I'll wait until this weekend to see if the light goes. If not, I'll pull out the cluster again and make sure I clean it properly.

MPGs, well, yoiu really cant tell by just looking at the gauges. I have not ran more than 25 miles since Sunday.
 

·
How far can I take it?
Joined
·
421 Posts
I just remembered. When I just bought the car my bro and I was cleaning up the engine. And we removed a gasoline saving device, cube like, I believe was a magnet clamped on the gas line from the fuel filter. We removed it since we believed that that really does not work.
But the former owner might also have had problems with mpgs that's why that thing was installed. There is no difference with or without that device.
Next chance I get Im changing the front O2 sensor.
Could there be anything else that I have not done?
 
1 - 20 of 31 Posts
Top