Nissan Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
so my temperature guage is not working 100% of them.. so heres what happens..

It use to show that the temp was little more then half way up which was normal for my car. Now all of a sudden, the needle is only about 5% up , then when the radiator fan turns on, the needle jumps to around 3/4 the ways up.. any ideas what may be wrong?
 

·
Shift_THIS and ZOOM ZOOM
Joined
·
370 Posts
i have a similar problem but when my car starts to warm up the fuel and temp gauge go right to empty and 0 on the temp then it starts to fluctuate going up and down erratically
 

·
Nissan/Mazda Gumshoe
Joined
·
1,052 Posts
hey guys. i had the same problem and got the answer from this very forum. u need to replace ur dash voltage regulator. its a little silver box on the back of ur guage cluster. if u guys like new stuff on ur cars then prepare to shellout 45 bucks at ur local dealer. otherwise , go to ur local salvage yard and pick it up for about 10 bucks and no one will be the wiser. i hope this helps
 

·
Still moderating..sorta
Joined
·
1,324 Posts
LoOod does your fuel gauge do funny stuff too?? If it does then you can almost be certain it is the voltage regulator. If not then you might want to look into replacing the thermostat or the coolent temp sensor.
 

·
Still moderating..sorta
Joined
·
1,324 Posts
LoOoD said:
my fuel guage work fine .. no problems with it..
It's NOT the gauge cluster voltage regultor that is your problem.
 

·
Ex-mod/nissan guru
Joined
·
2,136 Posts
maybe its a bad contact with the sensor itself... check it.. its below the distributor... 1 wire, ... maybe its shorted...
 
1 - 7 of 7 Posts
Top