Nissan Forum banner

1 - 6 of 6 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Well I finally dynoed my car. For those of you who aren't familiar this is what I have.

98 Sentra SE with GTi-R Manifold and turbo. T04B compressor housing. Manifold, Turbine Housing, Exhaust elbow extrude honed and swain coated. Fmax intercooler and piping. Greddy cat back exhaust, Greddy BOV, Blitz SBC boost controller, Cobra MAF, JWT fuel rail, MSD 50lb/hr injectors, Cobra POP, VDO guages. I also have 3bar turbo program with water injection. The water injection isn't hooked up yet.

I dynoed the car in 4th gear at 14psi on 93 Octane pump gas. This was my 4th pull. The first pull was similar to this one. The 2nd and 3rd pulls dropped about 30-40hp beacause they were back to back runs w/o a fan blowing on the intercooler and no cool down time. The 4th pull we waited 15 minutes and had a fan blowing on the IC the whole time. All the pulls were done with the water injection map turned on with no water spraying. I didn't realize it was on.

I put down 266whp and 242 ft. lbs of torque.

I'm quite please with the car and again have to thank Rob Cadle and Mike Kojima for all their help.

Dyno


RK
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #3
No I haven't installed the water yet. Two reasons I had a MIL because the rear O2 resistor JWT put in didn't work. Apparently it works on some cars and not all. So with the MIL already lit I wouldn't know if the water was on or not. I sent the ECU back and JWT gave me an external wire to hook up to a lamp. I hooked it up to the E-brake and that worked like a charm. Took 10 minutes to hook up.

Secondly I haven't quite figured out how to wire the water in yet. Lots of wires. Aaron says most are not used. I may call him tonight to go over it.

Also I need to hook the MSD back up but somoene hasn't gotten to me with directions on how to hook it up externally to a internal coil distributor. Hint Hint.

I did not here any detonation. I'm not sure what smoothing factor the dyno plot was created on so I can't tell if the jaggies are detonation or just the smoothing factor is low. I'm figuring no on detonation though. We still have 93 octane over here.
 

·
NPM Executive Editor
Joined
·
214 Posts
RaySeNxSE-R said:
No I haven't installed the water yet. Two reasons I had a MIL because the rear O2 resistor JWT put in didn't work. Apparently it works on some cars and not all. So with the MIL already lit I wouldn't know if the water was on or not.


Use the simple persons test method and put a hose on the end of the nylon tube for the H20 inj and stick it out the hood. Believe me I wanted to make sure the water was working when the daughter board activates.

Originally posted by RaySeNxSE-R Secondly I haven't quite figured out how to wire the water in yet. Lots of wires. Aaron says most are not used. I may call him tonight to go over it.


I'll send you a number you can reach me at. But I wont be home till about 10 pm my time if you want me to go over my wiring. Will Thursday work for you?
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #6
SR20AL said:

I'll send you a number you can reach me at. But I wont be home till about 10 pm my time if you want me to go over my wiring. Will Thursday work for you?
Yeah thats fine.

RK
 
1 - 6 of 6 Posts
Top