Nissan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
sometimes when i start my car, my car will idle at like 2000 rpm! but here's the thing....if i wait a long while, it sharply drops down to where it should be. sometimes it doesn't drop down, so I'll go drive and while i'm driving, my rpms will be about a whole 1000 rpm higher than it should be, but sometimes it will drop down to normal again. what's wrong, is there an electrical problem, or do i have something in my pipes?? help me out, because it's really annoying, and I'm not sure if I'm wasting more gas than I should be. this has been going on for like 3 months.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
the thing is, I gave my car a little tune up about a month ago. I replaced my fuel filter, my cap and rotor, egr valve with a crank case breather (looks like a tiny intake filter), and changed the oil at the same time. do you think I need to flush my coolant, or that doesn't matter? maybe it's time to get rid of my vitek 8mm wires (i've had 'em for 2 years) or change my denso iridium plugs (2 years also)?? i don't know how long performance plugs or wires last, do you think that would cause my erradic idle?
 

·
Registered
Joined
·
500 Posts
The EGR valve shouldn't have a breather on it. It's supposed to have a vacuum line hooked into it from the intake pipe. That may be the cause of your erratic idle, because the vacuum system is broken in one place like that. Not to mention it will most likely dirty up your engine compartment.
 

·
Doodeee doodee doodee doo
Joined
·
1,495 Posts
check your cables, your accelerator cable may be too tight, or might've been pinched when you did your modding. If it is the cable, try pushing up on the gas pedal from underneath. If your idle doesn't go down from there, it's something else.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #6
allright, thanks guys. I'll check my cable and my egr valve. buuut, I'm not sure if it's called the egr valve or the pcv valve. so either way though, i should probably get rid of the breather to see if that's the cause right? well, i'll try all of this tomorrow since i have to work right now. thanks guys.
 

·
Boost anyone?
Joined
·
1,625 Posts
I think it might be your breather filter but i dont think you had it hooked up to your EGR valve or your PCV valve. Are you sure its not just hooked up to your crank case where the tubing to the intake tube was??
 

·
Registered
Joined
·
48 Posts
Discussion Starter #8
ummm...how about this - i'll post up a picture of where my little breather thing is. i'm pretty sure it's in the right place. i don't know what the heck it's called, but i did change my little breather along with my other small tune up additions.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #10
oh, sorry guys. my bro took my digital camera for the weekend. however, my camera does record 60 second clips with sound. however, my car is idling strange, but it doesn't affect the sounds at all.
 
1 - 10 of 10 Posts
Top