Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hello all, new Nissan truck owner. I purchased a 1992 2.4L 4x4 with 280k on it and would like to make it over 500k. However, I'm having some issues starting it. I replaced the battery after trying to jump start it, but the battery was fine. I replaced the ignition switch and the truck started up great the first few times. It sat for a week and then I couldn't start it again. I am not getting any lights in the dash, no clicking or any sort of noise. When I turn the key the dash clock dims and then resets itself. I replaced the ignition switch again, but that didn't help it to start this time. I have checked the fuses under the driver's dash. Any help or advice is greatly appreciated.
:confused:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
check you connections for the positive and negative terminals at both ends. probably corroded at the starter or have a bad ground.
Thanks, I'll check that out. I noticed when I changed the battery that the cables were a little corroded, so I cut them back a little bit. When I installed the new ignition switch it started right up without any problem, so I didn't think it would be the cables.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I changed the battery cables today and the issue is still there. Anytime I turn on anything electrical (dome light, headlights, etc.) the clock goes dim and resets itself. The negative cable was too short to attach to the ground on the engine so I attached it at the midpoint on the passenger fender. Is that not good enough? Any other suggestions?
 

·
Registered
Joined
·
10 Posts
I'm pretty sure the negative cable needs to be connected to the engine block as well as at the midpoint grounding to the body. Definately sounds like you have a grounding issue.
 
1 - 5 of 5 Posts
Top