Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
HI, I'm new here, and I have a Nissan Stanza Wagon GE 2WD circa 1984:idhitit:. My problem is that whenever I turn on the heater for more than about 15 minutes, the interior fogs up, although the heat still comes through. The previous owner, whom I consider to be very knowledgeable, said I must have some kind of leak in the heater core. I was wondering how to fix whatever this is, weather anybody else has this problem, where to source a replacement core from and how to replace it. Or I could be completely wrong and need something different.

Help me...
 

·
Registered
Joined
·
18 Posts
Heater core is correct!

I haven't had the pleasure of changing one in a Stanza but I've replaced 10 - 15 of them. Hopefully you don't have A/C. Sometimes the core can only be gotten to by removing the A/C lines. You don't want to do that because then to have A/C again you have to take it to a shop. They will want to replace the dryer and then recharge the system and that can get spendy. Or you can just not have A/C.

Or maybe you won't need to deal with the A/C hoses at all. I guess what I'd recommend is go to your largest library in town and see if they have All-Data! It's a computer program that some libraries have that will give you step by step directions on how to do a job. Not just in general but exactly how to do it on that vehicle!

Or just dive in! I hope your not a large sized guy because laying in the floor of your car upside down really suck! Even when your small!
 
1 - 2 of 2 Posts
Top