Nissan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hello everyone,

My friend and I are neck high in engine troubles. A little background info:

Friend bought a white SE-R from a guy named Corey... He's a member here I believe. The car, we believe, was turboed before the engine was blown. Corey then *swapped* in a high port SR20 and never proceeded to hook anything up.

Our problem arises because we have no clue where many of the electrical connectors go. We also don't no where/which vacuum hoses need to be used. I've tried to find a walkthrough or a guide to hooking these things up but to no avail. If anyone could point us in the right direction or lives in the Central VA area that would be willing to help... please drop a line.

I also have a few pics up on webshots that yall can look at:
Here
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
I've got it, thanks. I'll probably be working on it again, since it's in my driveway. WHen looking at the photos, do you see anything blatantly wrong that needs to be fixed? Thanks in advance.
 

·
even better the 2nd time
Joined
·
2,719 Posts
just glancing at the photos i cant really see much wrong

but im horrible with electrical problems...hopefullly someone more knowledgable will see this thread and reply

--why does the line running from the fuel filter to the fuel rail have 'not for fuel injection' written on it? (but im sure at this point that's the least of your concerns)--
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
we noticed that last night... think we got the wrong line. We really dont have much of a clue where all the vacuum lines go to/from. Any help is much appreciated
 

·
even better the 2nd time
Joined
·
2,719 Posts
looking at your pics, this needs to be like this (with a hose, of course)

sorry i cant sit and examine them more...i have to keep my window real small while im at work :(
 

Attachments

·
Registered
Joined
·
25 Posts
Discussion Starter #9
thanks, we've got it to turn over now, just cant get it started... will and of the vacuum hoses prevent a start? We are going to check the fuel pump tonight. Any critical fuel lines I need to know about besides the one with the wrong line?
 

·
even better the 2nd time
Joined
·
2,719 Posts
not that i know of off hand, but im no expert

and a vacuum leak shouldnt prevent it from starting i wouldnt think...it might make it run/idle funny, but id think you could still start it (unless of course it had no compression, but im sure it does)

maybe if you posted a detailed question as to how its acting youd get a better response.

like is the motor even turning over? are the accessories working? can you hear the fuel pump whir when you turn the ignition to the 'on' position?
 
1 - 10 of 10 Posts
Top