Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
Its getting really hot here finally and I don't have working A/C. Every once in a while when I start the car (with the A/C off) I get some sqealing from the belt. Then, if the A/C is turned on, I get this loud death squeal from the belt.

So what should I look for to fix the problems? I know that belt replacement is probably #1, but is there any adjustment or are the serpentine belts self-adjusting? If the belt is at fault, great. What if the A/C still doesn't work, what should I look into? Are problems with the compressor common with these cars?

Thanks for any help,

Nick
 

·
Registered
Joined
·
674 Posts
Chances are it is your a/c belt. The reason it gets louder when you turn your a/c on is because the compressor is putting more stress on the belt causing it to slip more. Replace the belt and you should be fine.
 

·
Ex-mod/nissan guru
Joined
·
2,136 Posts
also you can put WD40 on it... if its tight enough the squealing is coming form the side of the belt running on the groove of the puley... spray it good, if it doenst stop change it !!
 

·
Still moderating..sorta
Joined
·
1,324 Posts
Crazy-Mart said:
also you can put WD40 on it... if its tight enough the squealing is coming form the side of the belt running on the groove of the puley... spray it good, if it doenst stop change it !!
WD40 is probably bad for the rubber. Adjust the belt, if that doesn't work replace it. Another trick is to rub a bar of soap on the belt, it doesn't degrade the rubber but stops the squeeking.
Don't ask me why, but it works
 
R

·
Guest
Joined
·
0 Posts
Crazy-Mart said:
also you can put WD40 on it... if its tight enough the squealing is coming form the side of the belt running on the groove of the puley... spray it good, if it doenst stop change it !!
Ive always heard that if you do this then the noise will get louder do to lubricting the pullys.
And the the pullys just spin more. But thats just what Ive heard..
 

·
Registered
Joined
·
292 Posts
just change it . its really not that expensive to do. there are alot of problems with B12 A/C I disconected mine from inside the car so it wont ever run lol.. IT pissed me off i converted it to R134A and the fucker ran for a week great! then went hot again. I was going to Rip it out and save on some weight but then i thought damn I would love to have A/C again so im just waiting till i get enough money to put a new cars A/C system in mine if I can.
 
1 - 6 of 6 Posts
Top