Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 86 200SX perfect condition and only 86k miles and 2 weeks ago the speedometer stopped working along with the mileage counter. everything on the dash works perfectly. I'm having trouble with seeing if the car has a speed sensor, or just a cable or does it send a signal to emc control box? I want to fix this asap cause like i said the car is in perfect condition all original a/c works a perfect car.
 

·
Sup Mod keeping the peace
Joined
·
6,179 Posts
The car uses a speedometer cable between the tranny and the speedo head in the dash. The problem could be the speedo gear in the tranny or the cable itself or the speedo head in the dash.
 

·
NF Mod/Nissan Master Tech
Joined
·
9,361 Posts
Speedo head failure was pretty rare on those models. Bad speedo cables and stripped teeth on the plastic pinion gear were a lot more common "back in the day".
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Where is the location of the cable on the transmission and do you know where I can see a picture of it so I know what I'm looking for
 

·
NF Mod/Nissan Master Tech
Joined
·
9,361 Posts
I don't have a picture of the cable, but I can link you to a picture of transmission which shows the location of the speedometer pinion, to which the cable connects:

Manual transmission, CA20 engine:

https://www.nissanpartsdeal.com/parts-list/1986-nissan-200sx/manual-transmission-transaxle-fitting.html?Diagram=320_A01

Automatic transmission, CA20 engine:

https://www.nissanpartsdeal.com/parts-list/1986-nissan-200sx/auto-transmission-transaxle-fitting.html?Diagram=310_A01

It should be on the passenger side of the transmission in either case.
 
1 - 5 of 5 Posts
Top