Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
323 Posts
Discussion Starter #1
A while back I took the plunge and stuck in the indiglo giages which actually look great, I didn't take off any needles but my speedometer is off a wooping 17 mph, and that's base off, it's exponential now, the faster the more, when I go 75 it says 53, anybody have an idea of what to do, how to fix, where to get a new one? it got me a speeding ticket because i didn't know it was off that much, but that same problem got me out of it so yea.
 

·
what?
Joined
·
2,704 Posts
Hey,
All you did was get the needle stuck on the beginning of its swing. I don't know how, but that's what happened. The exponential factor you see is simply due to the oval shape of the speedo and the angle of the numbers on the face to the needle base. Once you take off the needle and reposition it about a few degrees down the problem should disappear.
Of course this is contingent that your indiglos are for the correct engine type to your car. 130 mph for 1.6L, 150 mph for 2.0L.

Seth
 

·
Registered
Joined
·
323 Posts
Discussion Starter #4
heh, now it's too fast, i ended up taking out the instrument panel and fiddling with it in the shop(I work at Best Buy's install bay and no we're number one in the company so we don't suck like the rest) and i got it remotely back but now it's too fast, i don't want to remove the needle entirely so I figure I'll have to keep messing around until I get it close enough or almost perfect.
 
1 - 6 of 6 Posts
Top