Nissan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
Every once in a while when I get in my car, start up and take off my speedometer stays at 0 ---- After I hit right around 40mph the speedometer jumps right up to where it should be. And other times usually when it if i give the cluster a smack it jumps up and back to zero if i'm under 40 mph... is this just a loose cable or something to do w/ computer?
 

·
Banned
Joined
·
126 Posts
Dude, I don't know whats wrong with your speedometer but,
I LOVED ALL YOUR CD'S
ohh wait... thats MAKAVELI... my bad

mad props to my N*gga tupac
HAHAHAH
 

·
Registered
Joined
·
205 Posts
I think it's some flaw in the speedo, mine does it when it gets below about 50 degrees farenheit. Once I hit about 20-30mph it pops back and works fine. I'm pretty sure that sticking doesn't do much good for the accuracy though, hehe
 

·
Registered
Joined
·
127 Posts
Discussion Starter #5
The check engine light never comes on. Just the other day though the brake light and battery light came on when i was on Empty and as soon as i filled up they disappeared. Weird huh? -- Also the other problem is that this is happening when is like 80 degrees....
 

·
Registered
Joined
·
127 Posts
Discussion Starter #7
well i just got back from the nissan dealer... They say it could be either a part on the tranny (38.99) or a whole new speedo (190 + 25 to set miles) --- Anyone else agree be best to get whole new cluster?
 

·
Registered
Joined
·
762 Posts
hey about a month ago my brake and battery light came on at the same time... only the brake light was kinda dim. well... 2 days later my alternator went out. i replaced it and both lights went out. just giving some forwarning.

hit up the salvage yard in your area and get a used one. that is if nissan will calibrate a used speedo.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #10
ga16tosr20.... damn fine warning you gave me... drove up to pep boys bout an hour ago to get a haynes book and my F'ing alternator died on me... Only thought to have it tested b/c of your warning ... good lookin out
 
B

·
Guest
Joined
·
0 Posts
It's just a flaw with nissan's. Honestly I think they should've done a recall. I've seen this problem posted way too many times. Dude, it's the cluster. It's happening to me too! My check engine light goes on also. I took my entire instrument cluster apart and played with the speedo cluster. While I was in there I took out my check engine light bulb. That resolved one problem. My speedo cluster worked for a while but now it's tweakin' again. You could go to the dealership but they will charge you about $200.00. But they will get you a new speedo with your mileage registered. Or you could go to the junk yard and get one for about $30.00. If you choose the junk yard you have to call the dealership where you purchased your nissan let them know you replaced your speedo cluster and what the new mileage is. It is very important to register the new mileage so as not to break the law!
 
1 - 12 of 12 Posts
Top