Nissan Forum banner

1 - 4 of 4 Posts
H

·
Guest
Joined
·
0 Posts
Discussion Starter #1
well while removing my gauge cluster to replace a bulb my speedo cable came off of the tranny can anyone help me to fix this it wont stay put
any help please thanks in advance
 

·
Registered
Joined
·
547 Posts
Ok, this happened to me once. I'm glad you have a 92...it's not electronic :). Alright well anyways. Get a buddy with you, and either of you get one end of the speedo cable down towards your trans. and one of you in the car. If it won't go in from just you trying to screw it in, then have your friend pull the car forward a little, or backward a little. Does the same thing so it doesn't really matter which direction. Do it slowly!! And don't get run over...sounds funny but it can easily happen. Anyways, while he's moving the car forward or backward, keep trying to push it in and screw it down a little bit. It should pop in there and give you enough time to screw it in a little bit. If this doesn't help post again. But it worked for me.
 

·
Registered
Joined
·
52 Posts
Well, if the speedo cable itself is damaged, you could have your local speedo shop repair it. I got mine repaired for $18.
 

·
Registered
Joined
·
301 Posts
$18?! Since we got our '91 Pathfinder 10 years ago, it's been making a harsh buzzing noise, almost like a rattlesnake, inside the instrument cluster, in cold weather, and until it wams up. If it is a snake, presumably it would make more noise the warmer it is, not less.

I've always suspected the speedo cable, but did nothing further because I was told by a Nissan dealer that a new cable costs $200 just for the part. Oddly, in 10 years it has only gotten slightly worse, and the speedometer works fine. The needle does not jump around.

Any adivce?
 
1 - 4 of 4 Posts
Top