Nissan Forum banner
1 - 12 of 12 Posts

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
The FSM clearly states the rpm readout is from the ECU (we know its from the signal from the dist.) and the speedometer is from the Vehicle speed sensor.
Since these two measure different variables how could you get both from the same sensor ?

 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
Since they didn't touch your cluster check the VSS first.
You can try removing it and spinning it by hand and see if the speedo works.
Check the gears. Look for broken wires since the clutch has just been changed.
I had no problems when my clutch was changed, but then i did my own :)
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
yes, you are meant to remove it to fill and check the Trans Oil level.
Its so awkward to get at I just fill the correct amount of Oil.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
i would describe it as under the Intake/intake tube, on top of the transmission towards firwall.
I wll see if I can get a picture and post later.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
See comments is your post below.

where is the vss speed sensor ? under hood up near firewall behind steering wheel side ?
or is it inside up under feet behind dashboard ?
any pics of it ?
thanks !
---

I have 96 nissan sentra 4cyl - and speedo needle drops to 0 intermittently
and the odometer stops rolling tooo....
And the check engine lite came on tooo ( about 5 months ago had fixed the EGR code w/ cracked vacuum hose and eng lite went off for 5 months now )... but now it's back on.
Yes this is very common, its a know problem here. I don't think this is the problem this time.
Is the speedo/odo problem reason for the check engine lite back on (probably)
YES

Will Autozone test computer show the code for this speed/odo problem ?
What is the code for this ?
Yes they will, look up the codes in the FSM or sticky, Autozone will also give you a printout of code number and an explanation

Best way to fix this ?
I won't be able to pass smog inspection with lite on, right ? (in Mass )
No this wont pass inspection even it Texas never mind MA !!!
speedo/odo going off seems when bad weather -raining and use wipers
Dont know if this means anything other than the temp that the sensor and transmission is at. If there is an intermittent contact could be temperature or even moisture Dependant.
Thanks
General location and direction of detail photo.

see VSS cable, see small part red wire showing and part of body.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
Hi
Sorry still not sure where/what red wire yur talking about in pic - Thanks for pic
Looks alotalot like my engine underhood.
Where is this vss cable or speedometer connection thing ?
Thanks
Ok try this, please remember this pic was shot on way to work, so it is from memory, but I am 70% sure this is it. If not its close !!! :)

 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
ok, lift hood and stand by drivers side wheel, near the master cylinder, look near firewall, below the Air intake tube, compare to the first picture
Then look down where its dark and you should see it.
Its on top of the transaxle above and between where the drive shafts exit.
Yes its difficut to see and to get at.
you can undo the one bpolt, and wiggle it out.
Others have reported its difficult to get out.
When its out you can spin it and see if the speedo moves up.
If it does check the gear on the VSS and the gear in the transaxle.
If it doesnt then check with a meter. I will look in the FSM and see what it says.
If its dead replace :)
If not then wiring and cluster, ECU ?
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
'96 Nissan Sentra GXE automatic - 127,000 miles : VSS problem :

Speedo/odometer just suddenly stops/drops to zero
and then by jiggling/pushing in/out/holding in the mileage trip reset button - usually speedo will come back to life. But dreaded CEL Light is ON - cant pass Mass state inspection with that on. (as you know)

............well this says to me that the problem is in the cluster.
---

My stupid story:
Last couple months CEL on then off then back on.
Went to Autozone - confirmed code 0500 then when CEL off - code cleared. BUt then now CEL back on.
The speedo acting wacky/dropping off to 0 intermittently.
--
I took my car today to official Mass. Emission repair place - garage mechanic guy who specializes in the CEL OBD thing. (He fixed another prior CEL code 0400 EGR thing for me before -only charged me $50)
All he would attempt to do/did was verify code 0500 on computer. Then just looked/checked under hood the VSS on transaxle - said it is prob ok.
(I had already removed trim panel around the cluster guage to help speed things up - save $$).
BUt he would not even touch/dive into pulling out the speedo/cluster guage or check wiring etc...

He said - anything involving speedo/odometer has to be sent out to place in NJ (one place he has used) and Dealerships must do same thing too.
And this "place" either replaces/repairs the speedo/cluster THEN resets the odometer mileage to whatever miles I got on my car. And then paperwork certifies it all and ships it back. All because Federal law or something due to truth with mileage/odometer law.


.............don't think so...
You can go to a Nissan dealer if you change the cluster and they affix a sticker to the door jamb with the millage correction.


IS THIS CORRECT ? Is this what happens or your experience in your state ?

Massachusetts has a pretty stiff/tough emissions inspection test - must pass emissions test every other year and Safety check every year.
---

He did at least reset cleared the CEL back to OFF and cleared the code.
BUt he said - still will need to drive car about weeek or 30-40miles city/highway to rebuild data in the ECM computer (ie: like cat converter info, engine rpm, etc etc) BEFORE can think about going for the state inspection test .

IS THIS CORRECT about having to drive around

YES

even after clearing the CEL light and ECM code ???

YES

How much time or miles have to be put on to fill up the ECM database so can take the inspection test ?
NOT SURE but a few hours 50 -100 miles seems about right

At least this guy is nice - did not want any $$ or charge me for slapping computer on or researching on his pc/internet sites or clearing out code and shutting CEL lite off.
(Gave him $20 bucks - least could do for his 45 minutes time)

Real life is: No good mechanic wants to deal with electronic/electrical messy problems like this - not worth their time (his words) and he is so busy with other customers - he/they won't screw around/waste their time (no matter how much $$ you might throw at them - not worth the hassles)
These good mechanics got so much other business/customers they don't need to deal with crappy/messy things like this. They can make easier more money fixing simpler stuff.

Your experience too ?
Yes, and customers get pissed when the expensive repairs don't work !!!
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
Same here but there is an option to say the mileage is unknown.
More than one or two people on the forum have got the dealer certification sticker adjusting the mileage.
So if this is a Mass thing your only option is mileage unknown. what if it breaks and its not fixed...Mileage unknown. they cant make that right if you are signing an affidavit.
Your car is OBDII
its an old car.... millage doesn't matter as much as condition, particularly in the snow belt because of rust.
Get another cluster for 50 - 60 dollars, get one same or near your mileage OVER and don't worry so much.
Look on Car-parts.com that's where i found mine, with a thousand more miles or so over but its close.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
Unfortunately many at $50 have not listed the mileage, so you will have to call around and find one
there are several listed at 130 131 K miles for under $100.
Car-Part.com--Used Auto Parts Market
look under instrument cluster, Auto 1.6 L, without TACH, 1995 to 1999
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,288 Posts
Well i am pleased you have your sticker for another year.

Please post your 13 steps to re-set the ECU.

No, i was saying when you sell the car there is an option here to check a box for "mileage unknown" instead of the mileage is Declaration / affidavit.

Yes they record your mileage every year and this shows up on the Carfax check for correct mileage. I don't know what mass does with this except report it as here.

Yes if you get a cluster that's close but above your mileage you can sign the affidavit and not raise red flags on the mileage check on carfax.

If the mileage goes backwards Carfax flags it as an incorrect mileage, don't know about Mass. Clearly then you must declare the mileage unknown or be guilty of Fraud.

I dont know about this book you refer too, not mentioned here before in last 5 years.

Please post your 13 steps to re-set the ECU.

Its been stated here that you have to go through so many start shutdown sequences and get car warm each time, numbers and distances were something like 10 cycles and 3 or 10 miles, cant remember.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top