Nissan Forum banner

1 - 5 of 5 Posts
L

·
Guest
Joined
·
0 Posts
Discussion Starter #1
What kind do you guys use for your GA16DE??? I have always used the one for the SR20DE in mine.... from nissan dealer...
 

·
Registered
Joined
·
170 Posts
Unfortunately I have Bosche Platinum +4 plugs in my car, and they suck!!!! As soon as I get around to it I'm gonna throw in the platinum NGK's for the SR20.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #3
hell yeah i have used those bosch +4 they are the shittiest plugs bosch has made.. that and the +2 arent any good either.. the regular platinum plugs are still pretty good..
 

·
Registered
Joined
·
205 Posts
I actually liked the bosch +4's but I think I've found out what the big issue is with them recently. I noticed that when I crank it up cold and let it warm up for a few min and drive casually it idles smooth and has smooth response, but if I drive it hard it starts to pre-ignite baaaaaaad (feels like it's misfiring even at idle and response gets really jerky when throttling). I'm guessing these plugs run hot so if you push it hard they'll get really crappy, but if you drive like grandma they aren't too bad. Soon as I get the courage to get ripped off at the local Nissan dealer i'm going to swap them out for factory plugs and leave the Bosch plugs for dead of winter driving, maybe they'll respond a little better.../shrug
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #5
97PocketRocket said:
but if you drive like grandma they aren't too bad.
shit that is the problem i do drive like grandma... like grandma on crack.... cant stay under 65 in the freeway or the car will explode.hahahah :D
 
1 - 5 of 5 Posts
Top