Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok all you 240sx pros in the forum. I just got through rebuilding my KA24de. It was all cool and everything, but when everything was all back together and I tried to start it, it was turning but it wasn't actually starting...(a nightmare come true) so far i have replaced the fuel pump, distributor, Fuel pressure regulator (FPR), and managed the ECU. still the same thing is happening. OMG someone please help...so frusturating!
 

·
KA24DET
Joined
·
1,000 Posts
Hybrid_korean said:
Ok all you 240sx pros in the forum. I just got through rebuilding my KA24de. It was all cool and everything, but when everything was all back together and I tried to start it, it was turning but it wasn't actually starting...(a nightmare come true) so far i have replaced the fuel pump, distributor, Fuel pressure regulator (FPR), and managed the ECU. still the same thing is happening. OMG someone please help...so frusturating!
Well, you need to be more specific. Is the engine turning over but not firing? If it is, and the motor is timed correctly, it is probably either a fuel or spark issue. You can test this by using starting fluid. First check spark at the plugs by yanking a plug, grounding the base of it, and having a buddy crank the engine and watch for spark. I need more specific information to deliver a more accurate diagnosis.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
bridrive55 said:
Well, you need to be more specific. Is the engine turning over but not firing? If it is, and the motor is timed correctly, it is probably either a fuel or spark issue. You can test this by using starting fluid. First check spark at the plugs by yanking a plug, grounding the base of it, and having a buddy crank the engine and watch for spark. I need more specific information to deliver a more accurate diagnosis.
I'll definitly try to be more specific. I'm going down to my dad's shop this Sat. so it might be while, but ill definitly give you a detailed report. It isnt firing, but is turning over. I'm definitly going to check it using starting fluid though..thanks alot!
 

·
KA24DET
Joined
·
1,000 Posts
Hybrid_korean said:
I'll definitly try to be more specific. I'm going down to my dad's shop this Sat. so it might be while, but ill definitly give you a detailed report. It isnt firing, but is turning over. I'm definitly going to check it using starting fluid though..thanks alot!
Yup. If it fires with the starting fluid, you have a fuel problem. If it doesn't, you have at least a spark problem.
 

·
Registered
Joined
·
48 Posts
just a suggestion

bridrive55 said:
Well, you need to be more specific. Is the engine turning over but not firing? If it is, and the motor is timed correctly, it is probably either a fuel or spark issue. You can test this by using starting fluid. First check spark at the plugs by yanking a plug, grounding the base of it, and having a buddy crank the engine and watch for spark. I need more specific information to deliver a more accurate diagnosis.
you think maybe the timing is off?
 

·
Locked and Loaded
Joined
·
1,227 Posts
fatboy509 said:
you think maybe the timing is off?
if its not a fuel problem.
 
1 - 6 of 6 Posts
Top