Nissan Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
A tad bit of background.

My 1997 Maxima was acting up for a couple months, occasionally struggling to start (and a couple times only lights came on when I turned the key). I took it to Firestone, they said it was fine, they just cleaned my battery. It was not fine. One day it just died on me, so I had it towed to the Sears auto center (it was a Friday night). The next day they said they couldn't fix it and had no idea what was wrong with it, so I had it towed to Nissan. After a few days they decided it was the ignition switch and replaced some electrical part.

End of story? I think not.

It just kept acting up, same problems, so I took it back to Nissan this week, and they finally decided it was the starter. So they replaced the starter and now it runs beautifully......

....but...

Now the Service Engine Soon light is on...I just picked it up last night and the light is on (not exactly sure when it came on, just noticed this evening).

Can the light be on because of the repair? Like they didn't reset it or something was put back loose or something? The care seems to be running just fine.

I wanna hit something...I am so worn out of this car problem and having to cash in favors for rides with everyone I know...

I would really appreciate any input you guys might have. I will be grumpily calling the dealership in the morning....I'm already down a grand, I really can't afford more...and I dunno when I can even bring it in....grumble grumble.
 
1 - 1 of 1 Posts
Top