Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

I have a 2001 Nissan Altima GXE, 55,XXX miles.
Few days back the car used to die out at stop sign or traffic light and soon after SES Light came on. Went to a mechanic, got it diagnosed and found out that it was an intake manifold gasket leak. Spent 600$ fixing this problem. Heard that this is a pretty common problem.

However, this problem came back again. The car dies out in R or D mode when stopped or low speeds. And when the SES light comes back ON, it just goes into this limp mode where it shakes while driving, chokes etc. The mechanic has checked MAF sensor but there is nothing wrong with it.

Does anyone know what the problem is ? How can I fix this ? This is really turning out to be irritating especially since THE SES light turns ON and car limps and is not drivable.

Thanks!
Prasad
 

·
Registered
Joined
·
8 Posts
Ohh man I'd need a little more info on this. This could be anything from the MAF sensor to Oxygen sensors to the intake manifold gasket again to etc.
The more I think, it's probably not the MAF sensor - I doubt that will have such a major effect on the drivebility of the car.
What are the new errors for?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hi,

Thanks for your message.

The error code has been P0100 (MAF sensor circuit ) consistently.

The mechanic now has replaced the wiring harness of the MAF sensor circuit and reset the code. Can the wiring harness cause such problems?

I will drive for the next couple of days and see if this has indeed solved the problem.

ALso, I was curious to know what are the standard RPMs when idling..that is when in Parking mode, as against in Drive/Reverse mode, and with and without AC ?

Thanks a lot!
Prasad
 

·
Sup Mod keeping the peace
Joined
·
7,044 Posts
The MAF itself may be bad; voltage readings should be performed while motor is idling; typical readings are 1.0 to 1.7 volts.

The idle speed is typically around 700 RPM.
 
1 - 4 of 4 Posts
Top