Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
Okay guys, my service engine light came on yesterday on my 98 200sx SE at like right at 72.9k..... possible problems? I'm already resetting the ECU as we speak right now. A buddy of mine told me his light came on on his accord at like 73k to have it serviced by 75k by the dealership and they turn it off. He said reset the ECU and it should shut it off if that's what it is. So if it's not, what should I do? I know the next logical step is to have a diagnostics ran on it but kinda strange for the light to come on with my somewhat-still-low-mileage lol. Hopefully it's just a sensor or something if it's anything at all?
 

·
Registered
Joined
·
191 Posts
Discussion Starter #2
Nevermind...... that's what it was, the dealership tune-up warning. Reset the ECU and it shut it off :D hehehe
 
P

·
Guest
Joined
·
0 Posts
Nissan has stopped doing that for a while.

Why didn't you just pull the codes to see why it lit to begin with?
 

·
Registered
Joined
·
191 Posts
Discussion Starter #4
What you mean pull the codes? Only way I know to do that is to have a diagnostics test done to it. And the reason I didn't do that to begin with is because it happend on my way to work that day and I didn't get off until like midnight that night. Woke up today and reset the ECU.

Problem now is that it was all good..... it shut off and never came back on. Tonight I was on my way home from work and at a red light headed out of town where the two lane comes to one about an 1/8mile after the redlight. I was chilling there and some car pulls up beside me (this is the biggest race-redlight in town LOL) and I look over and all I see is some steelies and that the car was black so I just thought it was some old POS from a quick glance. Light turns green and I pull off as normal and the guy starts pulling on me so I gave it a little gas to stay ahead of him to prevent following behind what I thought would be a POS..... all of a sudden I hear some exaust as he pulls up near me so I just punched it and pulled ahead of him LOL was kinda funny beings my 98 200sx SE is still stock until next week. Spanked his little civic ass. It was one of those ricey civics with big "Type-R" graphics all over it and some really raspy exaust.

BUT Anyways back to the point....... we kept going after the red light and he began to try to pass me so I let it go again and accidentally hit redline in 3rd gear..... check engine light came back on. What's up with that? Tonight I got home with 73,083 miles so it was roudly 73,070 when the light came back on. Guess I'll have a dianostics ran on it tomorrow?
 

·
Registered
Joined
·
186 Posts
you can check for codes yourself! I havent done it but ill be getting around to it sometime this week. Mine came on and i looked in my haynes manual and it gives really detailed instructions and what all the codes are so you may be able to fix it yourself! just go to your local autoparts store they should have a haynes manual. i think they are around ten dollars. they are the best things to have for any car! youll find it very useful when trying to do something on your car.
 

·
Registered
Joined
·
191 Posts
Discussion Starter #6
Well, had it tested just now. Result was random multiple misfires on multiple cylinders...... = bad plugs & wires. Picked up some NGK plugs today and hopefully I'll finda good deal on some nology hotwires on ebay maybe :)
 
1 - 6 of 6 Posts
Top