Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
so all of a sudden the heater on my 95 sentra won't blow hot air (or even warm). it's like the control is set all the way to cold, no matter if I turn it to hot or whatever.

I checked the linkage for the hot/cold control knob, it's doing what it should, as far as I can tell.

I searched on here to try and find the answer, and it seems like people with this problem either replace the thermostat to fix the problem, or they have a clob in the lines and flush the system to fix it.

Here's my question:

with the thermostat people replace, is there just one? (the normal one for the engine)? or does the heater have it's own thermostat that I don't know about that may need replaced? The engine seems to be heating up fine according to the temp guage, so I wouldn't think the thermostat is the problem (if we're talking about the normal engine thermostat.)

thanks in advance, by the way this is my first post so hi everybody..
 

·
Registered
Joined
·
27 Posts
yea, i had that problem this morning. It was simple for me yours might not be the same. I have an after market intake. The small hose that runs from my intake is what heats up the air i believe. It came disconnected and after i re connected it warm air came out again instead of cold. If you don't have a after market intake its on the rubber piece, its a small thin black hose that plugs into a hole on the stock intake. it might be that simple.
 
1 - 2 of 2 Posts
Top