Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
313 Posts
Discussion Starter · #1 · (Edited)
Hey Guy's
I have a rough start issue when cold. I just tuned the car up replaced everything as far as a tune up goes but I had a check engine light?? So I borrowed a Snap On Scanner and it said that there was an issue with the ground to the Mass air sensor or it might be open or dirty? So I removed it and checked it out. it did have some oil in the intake tract because of the serious oil leaks that this engine had. After that I drove the car and it was so so performance wise?? It wants to stall after being on the peddle??To reiterate the problems that I have it is very hard starting when cold? Once started and warm it is much easier to start again?? The second issue is when driving the car and coming to a stop it will just about come to a stall then regain idle?? Once a again the original code was the Mass Air Flow sensor,it said that the ground was inefficient??And to install a better ground? I also have noticed that the car when going over rough terrain will act like there is somthing very wrong as if there is a bad mount of some sort? After being under the car all day and looking around I saw that there was a cradle mount,could this be bad?? Sorry about the looooong post I just need to get this thing road worthy to commute. Oh I forgot to mention that i thought that the cheap Champion plugs might have been my issue so I went out and bout another set this time I bought Ngk's. Funny thing when I pulled them they read very lead just like the orginals that were completely spent,the only differance was the Champions had around five miles on them?? The fuel filter looks relitivly new,may be fuel pump issues?? What is the dilivery pressure supposed to be? Is there a fuel pump check out?? ................Thanks
 

·
Registered
Joined
·
313 Posts
Discussion Starter · #3 ·
It's definetly not a starter issue. It is also not related to the tune of the engine it's all new. I believe the issue to be drain back in the fuel system because it starts perfectly every time otherwise once warm. I have also noticed every once and a while I will go out first thing in the A.m and it will fire up emediatly. If I had the cash I would get a new pump but this one still working and I'm broke as a Joke Lol!!
 

·
Registered
Joined
·
430 Posts
iz summer so it's not a temperature prob.

fuel drain back would cause a hard start, but as long as the pump is working... it'd possibly be the fuel reg?? but i'm thinking it could be a small leak in the line, allowing air to get into the line after it's sat there for a while.

there's something else that had come to mind...trying to recall it.

only 3 things start a car and keep it going. fuel air and spark.

spark, as you know is easy to test. taking out a plug and checking spark... then working backwards along the circuit to find the prob. a cold atmosphere can cause probs within the battery but only in friggen alaska at this time.

air, easy to notice cuz you get better reaction when you push the pedal down as you start the car. not effected by when you're starting the car, unless the TPS is bad or the Throttle itself isn't opening.

so like you're thinking it's gotta be the gas. only things you've got... a fuel pump, fuel filter, fuel regulator, and injectors. and they're timed by the CPS and TPS. ....so if the pumps good, and the filters good, then that leaves two more...

injectors operate the same no matter when you're starting the engine (unless your harness has issues), so i'm guessing like you that it's draining back fuel when you leave it off for a while....


also guessing that the reason why some mornings it just starts right up is because you just happen to turn the engine off during the Intake Stroke.

the fuel pressure regulator gets rid of air in the line, and produces the exact pressure you need for the injectors. if that's bad it will cause this issue. but also.. if your lines somehow have sprung a small leak... same thing. air gets in system and then it takes a minute for the fuel pump to pressurize it again.

i might be missing something but not sure
 

·
Registered
Joined
·
313 Posts
Discussion Starter · #5 ·
What's up Och!Wher Ya been?? Ya IMHO this is fuel related Fo sure! I mean the car runs decent but when she's been sitten over night there s alway;s an isue!! I am going to trey a pump when I get out of Hospital and I will let you all know how it starts and runs......

Peace Bro!!
 
1 - 5 of 5 Posts
Top