Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
828 Posts
Discussion Starter #1
Greetings-

I have a 1996 Altima GXE that idles rough when the car is in drive and at a stop. It feels like the car is ready to die at stop. There does not seem to be a problem with the accleration or lack of power. In addition, there seems to be a slight whinning and gurgling noise coming from the engine compartment. I can't determine what component might be going bad. I was thinking either the alternator is making this sound or the water pump is starting to go, and no I have not looked at the weep hole yet. Below is what has been accomplished in-so-far:

0. Replaced the intake manifold gasket in January 2004

1. Replace the EGR vale, vaccume lines to and from it in November 2004

2. Basic tune up, fuel and air filters, wires, distributor cap, rotor and spark plugs. Got a side question on the spark plugs. I put in Bosch plugs and I hear NGK plugs are better. If so, why? and would this contribute to the rough idleing problem? tune up was done in December 2004

3. Replaced the distributor in December 2004. The car still died out and I brought it back to the shop and they said there was a vaccum line to the intake manifold not hook in and they cleaned out the throttle body with cleaner.

Since #3 has been done the car has been idling rough.
Please let me know if I am on the right track in troubling shooting this. but I was think the TPS might be either out of adjustment or bad, I am going to place a voltmeter to it and check it out. Any other suggestions?

On a seperate question, on the EGR temp sensor, there is a bracket on it. Since I had the intake manifold gasket replaced, I think the shop did not mount it back in the correct location. Right now it just dangles there by the thermocouple wire. So where the heck does this bracket mount to, I looked around and I can't find the location. I would need a picture to explain this one to me or refer. a page out the Haneys maunal.

Whew Well thats all

Thanks
Frankie D

p.s can some on reccomend where I can buy geninua<< Nissan parts for my car, and not at dealer please. I don't really trust after market. NISMO catalog? If so then where can I get my hands on one
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
I have found that NGK plugs work better for some reason. Partially I think due to the fact the engineers at Nissan designed it to work with that plug. Also for about $10 you could get the NGK V-Power BKR5E-11 and then compare to see if it makes any difference. If not well then you have plugs for next year.
I don't know if you got that service manual for the 97?, but the TPS should have 5v source voltage to between pins 1 and 3 on the bottom connector and after the car has warmed up it should read between 0.3 and 0.7v on pin 2 and ground or as the service manual says with the + on pin 23 and the - on pin 43 on the ECU connector. The reference ground is pin 43 but I haven't had any problems with using battery ground.
You may also run a can of 44K fuel system cleaner concentrate from BG through it with a full tank of premium fuel. This should take care of any dirty or sticking injectors.
The Nissan parts can be had at our good forum sponsors like Performance Nissan in Duarte CA at www.performancenissanparts.com or Courtesy Nissan in Texas at www.courtesyparts.com .

Troy
 
1 - 2 of 2 Posts
Top