Nissan Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
does anyone else have this problem or is it just me? Its been happening for a year now and just spent $400 replacing front suspension 2 months ago and the front struts still go out!!! Changed springs, struts, ball joints, inner and outer tierod ends, strut mounts and control arm bushings. any ideas?
 

·
Registered
Joined
·
34 Posts
maxpain said:
does anyone else have this problem or is it just me? Its been happening for a year now and just spent $400 replacing front suspension 2 months ago and the front struts still go out!!! Changed springs, struts, ball joints, inner and outer tierod ends, strut mounts and control arm bushings. any ideas?
what kind of struts are you buying? are the struts dust boots all torn up? are the bump stops non-existent?
i go through ball joints a little too often for my liking but that's about it for me.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
shock211 said:
what kind of struts are you buying? are the struts dust boots all torn up? are the bump stops non-existent?
i go through ball joints a little too often for my liking but that's about it for me.
used kyb g2's, monroe's, and gaberial's. OEM replacement. they all end up the same i'm busting the valve inside. no compression but one hella rebound. sounds like an empty spray paint can with the ball rattling inside. the bump stops are pretty much gone. was going to replace next time around.
 

·
Registered
Joined
·
34 Posts
maxpain said:
used kyb g2's, monroe's, and gaberial's. OEM replacement. they all end up the same i'm busting the valve inside. no compression but one hella rebound. sounds like an empty spray paint can with the ball rattling inside. the bump stops are pretty much gone. was going to replace next time around.
are you lowered?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top