Nissan Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
Hey I was going thru some old forums and I saw that someone had put this is...
hey ,

i got a 95 with 146000! and it runs GREAT D

jus got a check engine light on, tryin to fix it, my post is in the GA16DE section , help if u can ;o)

but it runs strong, replaced the alternator, starter back at 100,000, bought it at 90,000. I have to replace my rear drums though, they are CLICKING , why do sentras do that lol.

thanx
-1


... I HAVE THAT SAME PROBLEM!!! When I bought the car... it wasn't doing it, but after about 3 days of me driving it, it started clicking, sounds like something rubbing everytime it hits a certain point, well I had a limited waranty on it, and I took it back in, all those **** did was "re-adjust" the rear brakes again.... and what should happen about 3 days later??? The breaks start that shit again.... I'm not having any issues stopping though, but it just seems like its getting worse and worse! The dealership gave me a 6month, 60,000 warranty on the work they did, so I'm going to take it back.... again.... but anybody else had this same problem??? What did you do? Also has anybody had problems w/ leaks in the oil pan??? Cuz thats something else they said they fixed and about the same time the brakes started again it started leaking and burning off oil. Also I think I should have them check all my belts b/c they're letting me drive w/ oil splashing everywhere...
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,282 Posts
ditto0011 said:
I have to replace my rear drums though, they are CLICKING , why do sentras do that lol.

thanx
-1


... I HAVE THAT SAME PROBLEM!!! When I bought the car... it wasn't doing it, but after about 3 days of me driving it, it started clicking, sounds like something rubbing everytime it hits a certain point, well I had a limited waranty on it, and I took it back in, all those **** did was "re-adjust" the rear brakes again.... and what should happen about 3 days later??? The breaks start that shit again.... I'm not having any issues stopping though, but it just seems like its getting worse and worse! The dealership gave me a 6month, 60,000 warranty on the work they did, so I'm going to take it back.... again.... but anybody else had this same problem??? What did you do? ..
Yes very common, mine does it.
There is a thread here, I have started down the path to investigate. So far checked the lug nuts and spoke to the service writer at Courtesy Nissan.
He says very common, clean the shoes and drum. If that doesn't fix it install new shoes.
Good luck......
 

·
Registered
Joined
·
43 Posts
Is it a clicking or more of a thump? If it's a thump, it's possible the drum is warped or out of round and you need to replace the drums themselves.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #4 ·
Mekanik22 said:
Is it a clicking or more of a thump? If it's a thump, it's possible the drum is warped or out of round and you need to replace the drums themselves.
It is turning into a thump, at first it was just a click. But both times it's happened(the first time, then i got it fixed, then it started again), i could not feel anything in the brake pedal, and stopping performance is not effected. I also had someone sit in the back right seat(thats where its coming from)and they said they could feel it in the car. But in just the past few days, I am starting to feel a little click in the pedal everytime it makes the noise, but again, stopping is not effected. Now I used to have a Bronco w/ a warped drum, and i didn't hear/feel anything like this... I talked to carmax and they said they will go as far as replacing the drum, but there's NO way I'm paying for this...
 

·
Registered
Joined
·
62 Posts
re

my 98 sentra is doing it also, Guess i'll pop off the back wheels and the drums and check it out, i think i'll get some prem. wagner brakes. if it needs it or just a good cleaning. anyone have a jpg of the rear brakes after the drums are off.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #6 ·
I finally took my car back in and they told me that it was the suspension making that noise. Thats what I had told them I thought it was in the first place.... I guess they just didn't listen to me b/c they insisted it was the brakes. I am getting them to replace the rear shocks tho b/c thats what I told them was wrong in the first place and they documented that so they're fixing it all for free. Also they told me it was the oil pan leaking last time, this time they said it was by the timing chain... I guess, they said that it was "leaking from the timing" so I dunno exactly what that means.. But I went into the garage and they had the top of my engine off and I could see the cams and the timing chain, so i figured they were doing something there... I get my car back monday *sigh* I'm driving this gay ass civic in the meantime and its an Automatic :mad: I can't wait, also when im just like driving not really hitting the gas or anything (in my Sentra) I hear like this whining metal stress noise on the engine... I think it is just b/c its nearing 100,000 and its just normal noise but i duno, hopefully it had something to do w/ the timing chain being messed up...
 

·
Registered
Joined
·
62 Posts
re

I took my car in to see what was going on with the rear brakes, and the rear passenger side was the problem, the shoe was only touching on the bottom 1/4 on the drum. they cleaned the brakes and readjusted them, now it working fine. I also put in new ngk split fire plugs and new cap and rotor.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #8 ·
I finally got it bak!!! Well, I DID get it back on monday, but when i put it in reverse it was grinding and shaking like crazy(F#$king Carmax...) so, I TOOK IT BACK AGAIN and they said they put a mount in upsidedown???, and the brakes were STILL making that noise. They fixed the mount or wutever, and resurfaced my back brake... It did stop the noise! But now I am getting this funky grinding noise when I hit the brakes, and it only happens sometimes. I am fairly certain this noise is coming from the front tho, so its something I'm going to have to do myself. :banhump: Sry I just put that in there cuz its hilarious. Carmax told me tho if the same back brake starts making the noise again, take it back and they will swap the whole drum. So in a way I'm hoping that it will screw up again. Changing brake pads isn't hard is it? I changed them once on my bronco, and I know disc brakes are all pretty much the same, but theres no little trick or n e thing to changing them on a B14 is there? And yeh i think its high time I changed my plugs and rotor and all that. Are there any good brands or n e thing I should be looking into?
Thanks
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,282 Posts
IanH said:
Yes very common, mine does it.
There is a thread here, I have started down the path to investigate. So far checked the lug nuts and spoke to the service writer at Courtesy Nissan.
He says very common, clean the shoes and drum. If that doesn't fix it install new shoes.
Good luck......
Well I took drums off and cleaned it with brake cleaner. Did nothing else at all deliberately.
It was Ok for about 50 miles, then clicking and creaking came back.
SO
1) cleaning does make problem go away if only temporary.
2) Shoes are worn but not enough to replace. I get 3+ mm on the leading shoes and about 4mm on the trailing shoes.
Will let you all know what I do next.
BTW someone asked the length of the wheel studs.
On my GXE that came with steel wheels the studs are 25 mm long.
 

·
Registered
Joined
·
1 Posts
same problem 2001 Altima

I have a 2001 Altima and the same problem has developed in the rear passenger side brake. When I jack lift up the car and manually turn the wheel there is a resistance for about 1/4 of the turn. Taking off the drum makes the problem go away (All fixed!) so it must be something rubbing in the brake.

I am going to try cleaning the brakes. It sounds like replacing the shoes is the next step. I am trying to figure out a way to tell exactly where the rubbing is...
 
1 - 10 of 10 Posts
Top