Nissan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
Hey!

First off i'd like to say how awesome it it having a 4wd sentra.
I was testing it out monday with 12 inches of snow on un-plowed roads and that thing is a BEAST!

Anyway....Sometimes i'll pull up to a stop or the car will be parked and idling fine, and all of a sudden the engine revs will rise a lot, probably around 2500-3000 (i dont have a tach so i dont know). They'll stay there for a few seconds and then it'll smooth out. sometimes after this the revs will drop drastically almost to the point of the engine cutting out, but this has been rare. Tuesday I was driving down the road and it felt like the engine was surging and giving back when my foot was on the gas pedal, thought this might be because i was almost om empty. I hope someone has some insight on this. My guesses were maybe my idle air controller is sticking since it's been so cold, or I have a vaccume leak somewhere.

Thanks in advance!!!
 

·
Ex-mod/nissan guru
Joined
·
2,136 Posts
id check the idle air control and check also that the car get almost halfway on the temps guage.... to much lower and it will keep bouncing from "heat soaking" to normal idle ... if it is to much low, might be thermostat... other than that check for good connection at the water temp sensor behind the intake manifold...
 

·
Tha Sleepin' B12
Joined
·
175 Posts
Mine will rev up and down on cold mornings, acts like it doesn't know where to idle. I had a problem a couple months back where it'd idle around 3000rpm's and it was a busted vacuum tube...
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #4 ·
yeah, i just fixed the original temp sensor with the dash voltage regulator and it's always near the middle after the car has warmed up. The other temp sensor i installed after the thermostat always registers around 195 after the thermostat has opened so i'm positive there's no problem there. I'll pull an iac from a junkyard i guess. also i've been getting around 20 miles per gallon, i dont know if that has anything to do with it.

thanks for the replies.
 

·
Registered
Joined
·
87 Posts
i had/have the same problem with my 87 pulsar with an e16i in it. i changed the iac solenoid and it fixed the idling problem when the car is stopped. but my car still feels like it surges a little when the engine has warmed up
 
1 - 5 of 5 Posts
Top