Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hello everyone,

The other day when I was going to work, all of a sudden my car started making rattling noise at 70-80mph. I noticed that everytime I pressed the accel pedal, the noise would get louder, and the pick up suffered a bit. So I put the car in Neutral at 70mph and gave gas, the noise was still there but not as loud.

Then I took the exit, and as I stopped at a light, the noise stopped. When the light turned green, and as I accelerated, the pick-up suffered drastically and the engine was making a firing noise. Almost like a motorcycle engine like "pat, pat, pat... and it became faster as I accelerated.

I got to work, turned my car off and finally on my way back from work, the noise went away. Now the car's fine.

What could be the problem? Any discussion helps !!!

Thank you for reading this....2004 sentra SE-R, 2.5L
 

·
Registered
Joined
·
790 Posts
Any notice in coolant loss?
Do you have a header?
Did you loctite your butterfly screws?
Do you have a SES light?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
No coolant loss, No Headers....everything stock...except brakes lol

I dont' know if I have any butterfly screws missing..are you talking about the pre-cat manifold and butterfly screws???

About 1.5 years ago, my pre-cat was rattling and I put a used one from a junkyard. After that the noise went away but the check engine light's been on since then. (I should've just went performance headers at that point)

When I experienced this noise, and only once, this mechanic told me that one of your cylinders could be misfiring, maybe spark plug, or any coil issue

Thanks
 

·
Registered
Joined
·
790 Posts
No coolant loss, No Headers....everything stock...except brakes lol

I dont' know if I have any butterfly screws missing..are you talking about the pre-cat manifold and butterfly screws???

About 1.5 years ago, my pre-cat was rattling and I put a used one from a junkyard. After that the noise went away but the check engine light's been on since then. (I should've just went performance headers at that point)

When I experienced this noise, and only once, this mechanic told me that one of your cylinders could be misfiring, maybe spark plug, or any coil issue

Thanks
A used one from the junkyard was not the best way to go at all. I doubt that it's a spark plug or coil issue. If you dont have a OBDII code scanner you can get it read from Autozone. Knowing the codes help tremendously.
 

·
Registered
Joined
·
4 Posts
Possibly the spark plugs are dirty and is causing a misfire. That can explain the decrease in pick-up... Not entirely sure if that can make a loud sound.

It's worth it just to check it out.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
More to the story

OK so finally took a day off and got my SE-R checked out. (Saw a GT-R there and touched it...ahhhhh drueling..)

In any case, after the initial noise went away, last week, my engine oil went dry. Luckily I pulled over, checked my oil, and put in fresh new quarts(3). The funny thing is I just changed my oil 1.5 months ago.

Ok so I took it to the dealership to get it checked. They gave me a SES code of P0420 (for inefficiency in cat converter)

Beyond that, they pressure tested the engine and said my engine is shot...Internal failure and dosen't hold presure. WTF dude, nissan engine gets shot at 93K??? I dont' even race, given I do drive a little rough but the car is suppose to be driven that way....

BTW the estimated with labor of engine and new cat is about $6000-7000...
My freaking jaw dropped...I was planning on running this car to the ground and buying another SE-R but I'm kinda loosing faith in the SE-R's man...help..lol
 

·
Registered
Joined
·
790 Posts
It's the pre-cat that jacks up the engine. Also, 6-7k for an engine+labor is robbery. Shop around different shops. Altima 2.5L engines would work as well.
 

·
Registered
Joined
·
51 Posts
I feel your pain. I got the 100k warranty and with 792 mile remaining on it I'm getting an initial shutdown with the same problem. I'm far from leaving it at that though. I still owe about 3500 on mine and I'll be damned it I'm going to pay the remaining or 5k plus for replacement parts just because the 1 part that's not covered by the warranty screwed up everything else.
 
1 - 8 of 8 Posts
Top