Nissan Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
793 Posts
Nissan X Trail T30 2006:

Hi all,

My 2006 X Trail has had a few problems recently, it has never had an issues in the past, is serviced well and has 120000KM on the clock.

The first issues that came up roughly two weeks ago were an unusually long crank time, poor fuel economy and a noticeable petrol smell in the oil. The car never failed to start however and had great acceleration and power as usual when driving.

I decided to give it a decent service including; coolant, plugs, air, oil, and fuel filters and fresh castrol edge 5W-30. I even bought fuel pump assembly o-rings direct from nissan as I know these need to be replaced with every fuel filter change. This fixed the long crank time, but the oil has fuel dilution again and now the fuel consumption is incredible, over 16L to the hundred.

I have barely driven it since problems arised as im worried the fuel dilution will cause more severe issues but I'm sure to warm it up when I do. Just wondering if anyone else has had similar issues with their QR25DE engine and if so how they were resolved... or not. I'm thinking it may be an injector leak, mechanic booked for next week.

Cheers.
just a wild guess ( as you mentioned poor cranking..) have your mechanic look into the Cam and Crank sensors. We on this forum have all had to eventually replace them, including myself about 2 years ago.
- Search the forum on here for ''cam/crank sensors''.....and see if this applies to your current issues. If so, it's not a high cost part(s) and you may be able to replace yourself if you are mechanically inclined . Or pay your local garage to do it. Just ask around for reasonable quotes and don't get gouged. ;)
 

·
Registered
Joined
·
793 Posts
Tony has it right, when Nissan crank sensors start to fail they have a habit of missing teeth at cranking speed but not quitting completely. Because they don't go flatline and read correctly once the engine picks up speed, the usual symptom is a long crank with no codes.
I recall after i replaced my cam/crank sensors that my Xtrail just felt so much more smoother and maybe closer to what it felt like if i had bought the vehicle brand new. This was one of them rare times when it was actually cheaper to buy new Nissan parts from the nissan dealer parts department.
  • I asked a bunch of questions on this forum back then on best way to replace at home by myself. Had to also google and youtube the very few and rare videos on Xtrail repairs. But i did manage to replace both myself . The top of engine sensor was more difficult to get access too ( plus it needed a shot of spray lube , threads were on super tight) ....but with patience, determination and a good trouble light/ good tools, i got it out. Actually had to remove and reinstall within minutes as i figured i may have ''seated'' the sensor incorrectly. I wAS right. Reinstalled and cleared codes, good to go!
  • Same sort of issue when i replaced my oxygen sensor. Having read i may need a special tool or the oxy sensor threads may be seized up somewhat. Determination/patience plus some skill helped me remove it, install the new one and everything ran fantastic after that. :)
 
1 - 2 of 2 Posts
Top