Nissan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I searched and i cant find my exact problem. I just completely rebuilt my motor (ka24e) and put it in tonight. Had a couple little normal stuff and one big one. My motor wont rev past 2500 rpm. It idles great and then at 2500 it starts bucking like crazy almost like the rev limiter but a little sloppier. I took it out to see what it did under different loads and it does the same thing. The only thing that I know of that is wrong is a valve on the ps side of the motor has a vacuum line going in the top and two out the bottom.The bottom is broke but if i hold it on it doesn't change anything. I really think it is electrical but I cant find anything wrong and it didn't do it before I rebuilt it. Sorry the thread is so long but please help me.
 

·
Nismophiliac
Joined
·
1,517 Posts
I agree. it sounds like your distributor is shot. Try replacing the distributor, and checking the electrical connectors. I hope this helps solve your problem.

If you need any KA24E parts, give send me a message. I got a spare junked KA24E engine. It still has everything connected to it.


Good luck.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
Does anyone know how I can get a ka24e vacuum line diagram. My chiltons doesn't have one and I haven't been able to find one online.
 

·
Locked and Loaded
Joined
·
1,227 Posts

·
KA24DET
Joined
·
1,000 Posts
zellx2004 said:
If you need any KA24E parts, give send me a message. I got a spare junked KA24E engine. It still has everything connected to it.
Does it work???
 

·
Locked and Loaded
Joined
·
1,227 Posts
bridrive55 said:
Nice post!
yeah, search for downloadable and you'll find the FSMs online.
 

·
Nismophiliac
Joined
·
1,517 Posts
bridrive55 said:
Does it work???

Unfortunately, the people that owned the car before me didn't know what a rod knocking sounded like. So they drove it until it threw a rod straight through the block. It was funny to watch though. :thumbdwn:
 

·
Registered
Joined
·
23 Posts
Discussion Starter #12
Just so everyone knows I checked the MAF sensor and it seemed fine but due to suggestions and one more from RUNYUN I bought a new one and guess what. Its fixed. Thanx everybody, Josh
 

·
Registered
Joined
·
13 Posts
2lowpaco said:
Just so everyone knows I checked the MAF sensor and it seemed fine but due to suggestions and one more from RUNYUN I bought a new one and guess what. Its fixed. Thanx everybody, Josh
in the future if your 240sx wont rev past 2500 rpms its the maf. if you unplug it on a working one and try to rev it it will not go past 2500 rpms.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #14
nian said:
in the future if your 240sx wont rev past 2500 rpms its the maf. if you unplug it on a working one and try to rev it it will not go past 2500 rpms.
Thanx for that but I have worked on one in the past that wouldn't rev past 2500 rpm and was not the maf sensor. It ended up being the computer. My car was doing pretty much the same thing and I checked the computer and I thought the maf sensor was good, thats why I asked for help. Again thanx to those that tried to help. Josh
 
1 - 14 of 14 Posts
Top