Nissan Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
well some of you might be aware of the issues that i have been haveing with my $250 project truck, but incase you dont heres a thread to catch up with things.

http://www.nissanforums.com/hb-truck/149640-d21-crank-no-start-coils.html

well i got a dizzy from zanegrey, great helpful guy btw, off here and the truck will still not start so i guess its not a dizzy problem so he suggested that i pull the codes from the truck and this is what i got:

21-ign sig
23-idle switch
24-throttle valve switch

21 is kind of a no brainer cuz the thing just cranks, but are the other two only in there because the truck is just cranking and not running or am i way off base here in thinking this. thanks for any input that anyone has on this.
 

·
Registered
Joined
·
215 Posts
codes

if you can wait till monday i can give you the exact meaning of each code. give me the complete code(p....). i work at nissan so i have access to the mechanics service manual
 

·
Registered
Joined
·
85 Posts
Discussion Starter #3
i did the green light red light thing to pull the codes and this is what i got. no PO or P codes.
 

·
Registered
Joined
·
215 Posts
codes

the things i can get is the code meanings and procedures on how to check them
 

·
Registered
Joined
·
85 Posts
Discussion Starter #6
that is what i thought on 23, 24, and the main relay is passenger side fender right?

and when i am checking power at the coils do i check it in, back probing the connector or out at the coil wire to the dizzy? they both have power while not cranking.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #7
tested voltage at the main relay and had 10.5v while cranking. that is a 2v drop to the main relay but it was during cranking so....

and i had 9.5v out of both coils while cranking. this got me thinking about the condition of the wires. prevoius owner said that he did the wires about 7 months before the truck quit running, but i test the resistance of the wires from the coils to the dizzy and one was 2.25kohms and the other was 5.25kohms. is this enuf of a difference to cause this thing not to run??


i also noticed that there is some adjustment when putting in the dizzzy and was wondering if that has to be all the way to one side or the other.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #9
middle for the dizzy...<<what does this mean?

how do the wires look ?>>>wires look good. there not cracked or anything
and the should have an almost identical ohms test..<<possibly an internal wire failure?

check the lead coming into the dizzy ..>>>check for power?? cranking or not? that is the 4 pin connector right?

also looked at the fuseble links and they were all good.

i took up the vinyl floor covering and it was wet were the main wire harness runs from the ecu into the engine bay, water did not get to the ecu. thinking maybe a corrosion issue here?
 

·
Registered
Joined
·
85 Posts
Discussion Starter #11
ahhh i see. that is were i put it, i figured that was the best bet.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #12
checked power into the dizzy from the 4-pin connector and there was power there. than took the cap off and tested for power there and i had power there. also tested the resistance between the wires to the coils thru the cap and go the same result with different resistance values. i think im going to do cap, rotor,plugs and wires as a next step. this seems like the only logical step.......i think.


im getting kind of frustrated with it:confused: but i guess ill keep pressing on with it. might just break down and swap in the 350. lol :woowoo:
 

·
Registered
Joined
·
153 Posts
I had a bad rotor once,send the spark right to ground,instead of thru the cap.Look for burn marks on it,or a dark spot on the rotor,where the current was arcing thru.
Good Luck
 

·
Registered
Joined
·
85 Posts
Discussion Starter #14
i have thought about this as well. i was talking to the guys at work and a couple of them suggested that as well so i think that i will try it at least. $12 for a new rotor, worth a try.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #16
will do after work tomorrow!
 

·
Registered
Joined
·
85 Posts
Discussion Starter #17
got the cap and rotor........nothin:lame:

im really having a hard time with this, not sure were to go next with this:confused::confused:
 

·
Registered
Joined
·
85 Posts
Discussion Starter #19
that is all it is.

2 red
1 green

that is how i pulled out of the computer.
 
1 - 20 of 39 Posts
Top