Nissan Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
alright heres the rundown i figured out its not a turbo but here is my problem with it, the damn thing overheats after the first like 7 miles i replaced all of the hoses that have anything to do with the radiator/heater core, flushed the heater core and radiator made the switch to an electrical fan changed all the oil to royal purple 10w 40, the water pump is fairly new as is the thermostat but it still overheats, Im thinking its the head gasket, has anybody had this problem, IM also going to do a search for overheating but any new help would be greatly appreciated THANKS
 

·
ZPOOLNZ
Joined
·
1,609 Posts
Are you burning coolant? Is there white smoke coming out the tail pipe? The HG won't be the source of overheating unless your loosing ALOT of coolant. Did you change out the temp sensor at the bottom of the radiator?
 

·
Banned
Joined
·
3,554 Posts
Radiator core may be clogged.
 

·
ZPOOLNZ
Joined
·
1,609 Posts
jer28 said:
Be sure that you have bled most of the air out of the system.
Good point, this is a problem with the Z31.

You could get the core boiled and checked at a local radiator shop and then have the system flushed.
 

·
Registered
Joined
·
22 Posts
Trust me Ive done everything that you guys just said except for change the head gasket and also i learned that when the head gasket first starts to go out it wont blow smoke out of the tailpipe but it was blowing steam its gotta be the head gasket cause i lifted the front end up like 3 feet and it did nothing my next plan is to compression test the radiator and the heads. Thanks for your help any thoughts
 

·
Banned
Joined
·
3,785 Posts
Monitor your coolant loss, if any. If you lose a significant amount daily, if the car is driven every day, and there are no evidence of leaks on the ground, then you possibly have a BHG. Do a compression test first, for sure.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
i cant even drive it daily it overheats to the max top of the heat gauge and boils the water out of the overflow tank but its wierd cause it does ok on the street but if i take it on the freeway it overheats its only when youstart to get the compression up high that it overheats
 

·
Banned
Joined
·
3,554 Posts
Again, sounds like the radiator core is clogged.
 

·
Registered
Joined
·
7 Posts
e_tothe_j said:
alright heres the rundown i figured out its not a turbo but here is my problem with it, the damn thing overheats after the first like 7 miles i replaced all of the hoses that have anything to do with the radiator/heater core, flushed the heater core and radiator made the switch to an electrical fan changed all the oil to royal purple 10w 40, the water pump is fairly new as is the thermostat but it still overheats, Im thinking its the head gasket, has anybody had this problem, IM also going to do a search for overheating but any new help would be greatly appreciated THANKS
Have you visited "Z31.COM"? In the repair section, they have this kind of problem with an explanation on how to fix it.

Goodluck!!
 
1 - 11 of 11 Posts
Top