Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi everyone, first time poster here. My car is a 2000 Nissan Sentra 1.8 liter. It has 130,000 miles on it and has been a very reliable car. It has however, started acting strange recently. A few days ago I drove the car to work after it sat for a week. Upon starting the car the first time it immediately killed, I didnt think much about it and simply restarted the car. On my way to work the RPMs dropped and I heard a buzz noise coming out of the passenger side dash, than the O/D light flashed and everything went back to normal. On my way home from work it did this several times and the O/D light even flashed a code like sequence a few times. I figured some kind of sensor was messed up and I would take the car somewhere and try to get the codes read, so I parked the car until I had time to take it in. The car sat for 2 days and this morning I was going to take it in and when I went to start the car it did the same thing it did a few days ago, it died and made a buzz noise, it also made this buzzing from the dash when the RPMs would drop and the O/D light flashed. I restarted the car and it did the same exact thing except now the farker wont start. Anyone have this happen before? Any ideas on what to check/ replace to get the car back running? Thanks in advance for any ideas/ help.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks for the reply! I was thinking it was the TPS before it wouldnt start, but now that I have been reading about it I now know there was a recall on the cam sensor. I will check with the dealer and see if that recall has been done on it and if not this will be where I start. I may be wrong but I think the TPS would cause it to run like poo but not cause it to not start. The engine cranks strong so it is not a battery issue.
 

·
Registered
Joined
·
6 Posts
i know if your O/D light flashes its a fail safe mode for your transmission... usually the amount of corresponding blinks is linked to the problem from the sensor in your transmission.... And on the note of the cam position sensor.. I brought my car to nissan the other day and they had over 5 campaigns ( recalls ) on my car.. 1 is the cam position sensor ( the only code my car is showing) said it would be about to weeks to have it shipped in... So no problems yet.. I don't think it would be that sensor because the car simply wont start if the sensor is eff'ed up... It could be a tranny problem I suggest a mechanic asap before it costs you anymore money.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Well, the car is going to the dealership to have that recall done, codes read and anything else it may need.
 
1 - 6 of 6 Posts
Top