Nissan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
hi all iam new to this forum any who i have a 91 d21 that i turbo about a month ago works great runs awsome on 7psi, last weekend i had a problem with the motor i acted like it was running on 2 cyclenders did a compression check no 2 &3 were bouncing up then dead so i pulled the head gasket nuthing rong so i put a new one on then after fighting the timing and all that good stuff the problem was the dissy button had broke i no i should have checked that to but any who now in the whole tear down and rebuild i put the 240sx intake mani on
this is were my problems start she will crank up but if i let of the gas she dies and if i try to restart she just floods and wont crank up now if i start her the next day she does the whole thing over again mind you if i keep my foot on the gas she runs and reves up great, and some times trys to idle but no luck i really dont want to put the old mani on because it was a pain in the but to make this one work dose any one no what the problem might be iam getting tyred of fighting this thing any help would be sooooooo awsome
cheers
ed
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
also with the 240sx intake manifold i used the d21 injectors and fuel rail but with this i had to flip the fpr upsidown to clear the throttle
 

·
Registered
Joined
·
117 Posts
i did it and i had that but mine was in the vacuum i have the hb and the240 dia.if you want them but i used the 240 rail and injectors what maf are you runnin
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
the trucks i drilled a whole in some 2" pipe and screwed it in with some sealnt around the top i still dont get why it wont run right i started to think it might be the tps cuz that thing is drenched in fuel i have the turbo in the back and man dose that thing smell
 

·
Registered
Joined
·
117 Posts
c i had mine like that too but the truth is that you need that maf housing cause the air aint suppose to go right through it... its suppose to kinda pool around the sensor and if you have a turbo i reccomend runin the 300zx maf WAY BETTER did you leave the choke in the 240 mani? i didnt and shes little hard to start when its really cold 10 degrees also my intake is 3" idk if that help or not
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
you think the maf would make it flood really bad i do need to get a better maf like you said though and run it on the inlet of the turbo instead of the pressure side
 

·
Registered
Joined
·
117 Posts
your tps is bad mine just went out today so change that and you should be good to go
no leave it in the area it is in but just get the maf housing and do it that way no what i mean its like 50 dollars for one new
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
i tested it and its good i think it might be because iam running the d21 ecu and causing it to act up but i think iam going to put the stock mani back on and see if itl run then iam gonna order the 240sx injectors wire harness ecu and maf so that i have the whole kit and kaboodle ill let ya no if i still have problems with the d21 mani but it should run right
 
1 - 11 of 11 Posts
Top