Nissan Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi i'm dumb :dumbass:. I've got the whole 93 240sx hatchback thing goin. I just wanted to know what u all thought about a few of my problems:

1. My brother tried to jack up my car one day, unfortunately he owns a honda prelude and thought that this bar in the front of my car was the corresponding jack point on my car... jack slips off bar, busts a big dent in the radiator. Watcha guys think? looks alright to me! but i'm dumb. I think theres a hole in it kinda, just a small one. Kin i patch it?

2. Much more important than #1. My car makes a very loud clattering. Its really gay. My brother immediately said it was the exhaust (i dont know?), so he takes it to some exhaust place and they say its coming from the bell housing :(. Pull the bell housing apart, find the flywheel bolts loose, tigten them, and replace the thrust bearing. I put my baby all back together! and it still makes the noise... I sit and read stuff... i think it has to do with the clutch cover? the teeth on the diaphram thing were silver, as in they'd been worn. any ideas?
oh oh yeah and the sound... well it kinda went away for awhile, only making it when the car hit rpms above like 5k. one day i gas it pretty hard and when the rpms come down, the car makes the noise all the time, and MUCH LOUDER...

3. My car seems kinda shakey as well. Its like... if its in a higher gear, the entire thing shakes. it really blows. for example, 5th gear under 2.5k rpms just makes EVERYTHING shake. maybe some kinda mount or something?

4. the engine... Well my brothers car has 160 hp being a prelude si. mine should have 155, and since its about 50k miles younger, i would expect it to run MUCH BETTER. Surprise, my car seems so much slower :'(. what could cause such bad performance?

5. Related problem to numer 5? when i turn on the ac the car gets 2x as slow!! (1/2 x as fast! )

6. This should really have gone in after number 2, cuz its kinda important. When i put the tranny back on, wiring that went into the transmission fell off. I just put the wires back on but a buncha electric tape on it and those lil zippy thingies? ya think that might hold? i thought it did. the problem is that the one going to the spedometer sensor thing had previously been cut and put back together. I took the harness off at that point, and when it came time to put it back on, i just twisted the wires together, put some tape round it and called it a night. could that laziness be the reason my spedometer only works 1/10 of the time now? if it is, what should i do? souder the connection or something?

7. my front bumper sucks. the whole front end isnt aligned in a buncha places. (just felt like sharing that)
 

· Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
oh wow i forgot something else! VERY IMPORTANT

8. The car cant make it past 6k rpms. should it be able to? it just kinda like... stops working at 6k rpms, it jolts a bit then the rpms come down. is that like a misfire or something? maybe i need new spark plugs?
 

· All over your face!
Joined
·
7,106 Posts
best advice I could give to you that will save you alot of money in the longrun is to get an engine swap. Sounds like your going to need a new lower harness as well. So I would say pick an engine and then buy a radiator that corresponds with that engine. I would suggest the cheap route of going CA18DET. One of the cheapest turbo engine swaps. I would also find a good reputable shop in florida to do the work for you. No offense, but your post leads me to believe that your probably not going to be able to conquer the task.An engine swap may seem a bit drastic, but in the end probably alot cheaper. If you tried to sell your car as is right now, you'd lose money on it. Either way your losing money on it, but in the end an engine swap will pay off in your favor. For more information on engine swaps please do a search.
 

· Banned
Joined
·
5,533 Posts
Yeah it seems you have some serious electrical and engine problems and like Opium said no offence but you need to stop working on your car, because from what it sounds your not helping much.

Find a shop to either swap in another KA or the CA18DET. You might actually be able to find a KA for cheap. I know I've seen them around here a couple times for about 1K with under 100K miles on them.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top