Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys,

I have a question the fuse for my tail lights keeps blowing also not getting any dashboard lights. Is their a connection with the lights and the stereo. I had put a new stereo a few days ago, thats the only thing I can think of that could be making it go short. Any suggestions.
 

·
Registered
Joined
·
99 Posts
i had the same problem with mine it was i hooked up a light from my tach to the lights. sounds like you are pulling too much power for the fuse try going with a little bigger fuse and see if that works.
 

·
Registered
Joined
·
505 Posts
Hi guys,

I have a question the fuse for my tail lights keeps blowing also not getting any dashboard lights. Is their a connection with the lights and the stereo. I had put a new stereo a few days ago, thats the only thing I can think of that could be making it go short. Any suggestions.
You probably hooked up the DIM light wire on the stereo. This is bad and can fry you're entire dash. disconnect the Stereo and check, I believe this wire is usually orange. You may have fried your dimmer switch. Check the power to the switch, if there is power, it's toast. You can bypass the switch or replace it. This could also cause the fuse to blow.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Found the problem

For some reason the ground for the stereo came loose and was causing the issue. Thanks guys for all the help.
 
1 - 4 of 4 Posts
Top